Home Forums General Using Ctrlr 1590 – intermittent – MIDI settings greyed out in VST

This topic contains 8 replies, has 2 voices, and was last updated by atom atom 3 years, 3 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13725
    msepsis
    msepsis
    Participant

    I’ve had a number of reports of this from users, I think they’re all on os 10.8, where when they go to set their MIDI settings after loading the panel (i’m distributing restricted instances as VSTs) they can not select MIDI thru options as they’re all grey’d out.

    I experienced this once yesterday at the end of the day on a mac tower but was not able to reproduce it with my laptop… same software revs, same hardware, having trouble deducting what might cause this.

    Any ideas??

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #13729
    atom
    atom
    Moderator

    If those settings are greyed out it means that JUCE does not know it’s beeing run as a plugin (it thinks it is a standalone program). I can hardcode the settings to be always active, but i imagine there is a bigger problem here that might be causing this.

    I’d need details about what host, what version, what format (AU/VST), 64/32bits, exact information i can reproduce.

    #13731
    msepsis
    msepsis
    Participant

    I’ll get you details as soon as i have them all rounded up. I experienced it on os 10.8.5 in ableton, i dont recall if I had downloaded the 32 or 64 bit but I know I have 64 bit here on my laptop and it works fine – haven’t seen that issue.

    also for clarification it’s the plugin options that get greyed out, not the MIDI thru settings.

    VST (I thought we couldn’t make AUs?)

    I believe everyone who has reported this has said they were using ableton.. again i’ll do my best to round up all the details I can from ppl.

    Hey If I select the options while in reaper when I’m building the VST for mac could that trigger a “hard code” of these settings?

    I’ve been asked if I could hard code the settings so ppl dont need to check three things every time they load the plug in (input from host, output to host, Plugin Host-> Output Device)… is there any way for me or you to do that so when users load the plugin all they need to do is designate the MIDI in/out ports within the MIDI menu?

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #13732
    atom
    atom
    Moderator

    YOu can make AUs, i just can’t say if they work in instance mode.

    Anyway i’ll try to make those settings modifiable when exporting the instance, right now i specified to clean ALL MIDI options when exporting to instance so that MIDI device lists don’t get hardcoded into instances. But those options might be a good idea.

    #13733
    msepsis
    msepsis
    Participant

    ok one guy is on win vista running ableton live 8.3.4. He’s connecting the synth via USB, no midi interface which shouldn’t make a difference. When he tries in reaper everything works ok, the menu is not greyed out. i’m waiting to hear back if he’s on reaper 32 or 64 bit, ableton live 32 or 64 bit and vista 32 or 64 bit for that matter.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #13734
    msepsis
    msepsis
    Participant

    Here’s another guy’s detailed notes… very interesting and telling.

    bridged mFeld VST Version .106 in Reaper 4.402 64 bit
    Done with another PC (Win 7 64 SP1 i7 16GB RAM). Screen resolution is 1680 * 1050

    After loading mFeld VST to a recording channel the menu acts quite strange:
    – some menu entries are not accessible (e.g. Zoom in / out, MIDI Thru subitems, Input from plugin host, Input from host to comparator, Output to plugin host => so I am not able to setup the plugin correctly
    (This also just happened in Ableton Live 9.0.5 and here I found out that the menu entries get available as soon as I touch an editor control on the GUI which than also worked for Reaper).

    • This reply was modified 3 years, 3 months ago by msepsis msepsis.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #13790
    atom
    atom
    Moderator

    And the greyed out issue is something that JUCE does, if the window that uses the JUCE based ApplicationCommandManager interface does not have focus, the Menu system that uses that ApplicationCommandManager is greyed out.

    I noticed that plugin windows often don’t grab focus, i found that clicking on that small resizer corner in the lower right edge grabs the focus for the window and the menus become active. Try that.

    #13812
    msepsis
    msepsis
    Participant

    Cool. I’ve passed the info out and havent heard any complaints about the issue since. I’ll consider it resolved as there is a workaround and the cause has been identified. Not much for you to do to “fix” this, eh? as if give the window focus if they click the MIDI menu so the items can’t be greyed out?

    Curious – on this note, what is the new panel property “Use the editor wrapper for VST plugins” ? I think you added this as a result of my comment regarding the “this is a dumb wrapper”… i’m just not 100% clear what enabling this toggle does…

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #13815
    atom
    atom
    Moderator

    This exports an instance that either uses or not-uses the wrapper, you have control over you instance.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed.