Home Forums Platform Specific Linux Building r1657 on Debian Squeeze

This topic contains 3 replies, has 2 voices, and was last updated by atom atom 3 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #17631

    ricard
    Participant

    Hi,

    I’ve checked out the latest (r1657) Ctrlr, together with latest JUCE, and built the Introjucer. Have used it to adjust paths in the Ctrlr_Standalone.jucer file to match my installation, and run ‘Scripts/build_linux.sh Release’. A few files build, but when building CtrlrStandaloneWindow.cpp I get things like

    ../../../../Source/Application/CtrlrInlineUtilities.h: In function ‘const void mergeMidiData(const CtrlrMidiMessage&, CtrlrMidiMessage&)’:
    ../../../../Source/Application/CtrlrInlineUtilities.h:25: error: invalid conversion from ‘const juce::uint8*’ to ‘juce::uint8*’

    which make me feel like there is something really wrong here somewhere.

    The Demo applications included with JUCE compiled fine.

    I’m running Debian Squeeze.

    /Ricard

    #17633
    atom
    atom
    Moderator

    Well i just checked out the same revision and built Ctrlr, apart from a missing .cpp file (i added that to the repo now, part of juce) everything compiles fine, i’m thinking this could be a gcc version issue, what gcc do you have ? Here is my version:

    [atom@suonko:~/devel/ctrlr/Builds/Generated/Linux/Standalone]$ g++ -v
    Using built-in specs.
    COLLECT_GCC=g++
    COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.7/lto-wrapper
    Target: x86_64-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Ubuntu/Linaro 4.7.3-1ubuntu1' --with-bugurl=file:///usr/share/doc/gcc-4.7/README.Bugs --enable-languages=c,c++,go,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.7 --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.7 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --with-system-zlib --enable-objc-gc --with-cloog --enable-cloog-backend=ppl --disable-cloog-version-check --disable-ppl-version-check --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --with-tune=generic --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
    Thread model: posix
    gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1)
    #17634

    ricard
    Participant

    The g++ version would seem to be very likely. I’ve got 4.4.5 here.

    $ g++ -v
    Using built-in specs.
    Target: i486-linux-gnu
    Configured with: ../src/configure -v --with-pkgversion='Debian 4.4.5-8' --with-bugurl=file:///usr/share/doc/gcc-4.4/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.4 --enable-shared --enable-multiarch --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.4 --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc --enable-targets=all --with-arch-32=i586 --with-tune=generic --enable-checking=release --build=i486-linux-gnu --host=i486-linux-gnu --target=i486-linux-gnu
    Thread model: posix
    gcc version 4.4.5 (Debian 4.4.5-8)
    Attachments:
    You must be logged in to view attached files.
    #17638
    atom
    atom
    Moderator

    Try upgrading see if that helps

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

Comments are closed.