Home Forums General Using Ctrlr Increasing Ctrlr Modulators on OSX

This topic contains 44 replies, has 3 voices, and was last updated by  kwtsh 3 years ago.

Viewing 20 posts - 1 through 20 (of 45 total)
  • Author
    Posts
  • #21582

    kwtsh
    Participant

    Hi there

    I’m trying to get the Virus TI panel working on OSX 10.8.5 and have succeeded in getting it to work nicely without USB, just MIDI, TRS and SPDIF for sync only.

    Now I’d like to increase the modulators available to the Ctrlr panel as the TI apparently uses far more than the default 64 available. The Virus TI panel responds to know twiddling on the Virus, but only for some sections (not effects, arps, LFO3 etc) and I understand that I’ll need to increase the modulators to do that. The only instructions I’ve seen to achieve this are for the PC based VST. I’m using the AU version on OSX.

    I’ve tried adding a plain text file called Ctrlr.overrides into these folders:
    /Library/Audio/Plug-Ins/Components
    /Library/Audio/Plug-Ins/VST

    Here’s the contents:

    < ?xml version="1.0" encoding="UTF-8"?>

    I’ve tried both the AU and VST version of the panel in Ableton Live and tested the Virus TI panel, but havent yet been able to get it to respond to knob twiddling for the effects, LFO3 and arp sections.

    Can anyone verify the approach required to achieve this on OSX?
    How can I check to see if the panel now has the 3000 modulators available? I can view the Menu: Panel>Modulator List and goto view>visible columns and add ctrlrMaxExportedVstParameters to the view, but the entire column is blank for every parameter.

    How else can I test to see if the overrides has taken effect?

    Many thanks, Jon

    #21607

    dasfaker
    Participant

    Hi kwtsh

    You are missing the max exported parameters line. This is the text to include in the file:

    < ?xml version="1.0" encoding="UTF-8"?>

    < ctrlrOverrides ctrlrMaxExportedVstParameters="3000" ctrlrShutdownDelay="256" ctrlrUseEditorWrapper="1" ctrlrLuaDisabled="0" ctrlrLogToFile="0" />

    Remember that you with ctrlrMaxExportedVstParameters=”600” you cover only a single part, so put a number big enough to manage the parts you will need (3000 will cover 5 parts).
    The folder must be the same where your Ctrlr.au is located. Look if there is some Ctrlr folder with the .au inside
    /Library/Audio/Plug-Ins/Components
    /Library/Audio/Plug-Ins/VST

    The only way to know if it’s working is when you see that some of the modulators that don’t received midi messages begin to work.

    • This reply was modified 3 years, 1 month ago by  dasfaker.
    • This reply was modified 3 years, 1 month ago by  dasfaker.
    • This reply was modified 3 years, 1 month ago by  dasfaker.
    • This reply was modified 3 years, 1 month ago by  dasfaker.
    • This reply was modified 3 years, 1 month ago by  dasfaker.
    • This reply was modified 3 years, 1 month ago by  dasfaker.
    • This reply was modified 3 years, 1 month ago by  dasfaker.
    #21629

    kwtsh
    Participant

    Hi dasfaker

    Not sure what happened with my copy and paste, but the files are correct and contain the line:

    http://ctrlr.org/forums/topic/mapping-controllers-to-ableton-parameters-also-labels/

    where Atom was talking about:

    “The index must be below the max number of reported parameters.
    If you report 100 parameters you can’t have index 100 or higher only 0-99 (that’s a hundred parameters starting with index 0)”

    Which is why I tried also 500 rather than 3000…

    The full text:

    < ?xml version="1.0" encoding="UTF-8"?>

    On a Mac an Audio Unit (AU)’s file is called a component and lives here: /Library/Audio/Plug-Ins/Components

    VSTs are here:
    /Library/Audio/Plug-Ins/VST

    I’ve placed the ctrlr.overrides plain text file with the increased value in both of these folders and tried the AU and VST versions in Ableton Live, but dont see any difference to the behaviour of the Virus Panel. No more panel controls seems to respond to Virus Knobs than upon install. Midi is being sent from the Virus to the Motu and onto the Mac, confirmed with Midi Monitor.

    What am I missing?!!

    Thanks, Jon

    • This reply was modified 3 years, 1 month ago by  kwtsh.
    #21632

    dasfaker
    Participant

    I noticed the copy&paste issue too with my post.

    If you put 500, some modulators will not be working, remember the Virus panel has almost 600 exported parameters.

    Is the Ctrlr plugin in one of those folders? Can you post here the name this file?

    What is the name of your .overrides file? It must be the same name as the Ctrlr plugin with extension .overrides.

    The problem must reside here, in the name or the place of the file.

    #21635

    kwtsh
    Participant

    Thanks,

    Just tried with 600 as the parameter but no joy…

    Still things like LF03, Phaser, Reverb, Arp dont respond?

    Not sure what else we can try?

    Screenshot of files and these are in /Library/Audio/Plug-Ins/Components

    Sometime I’ve notice the Ctrlr Panel looks different, e.g. on the attached there are no GUI red items for the phaser section. Now I’ve increased parameters to 600 there is…

    Attachments:
    You must be logged in to view attached files.
    #21639

    dasfaker
    Participant

    Hi Jon

    The file is correct and the name too. It’s the way it should be.

    Could this be related?
    Does this happens with the vst, too?

    About the phaser, when Mix > 0 it lights-up the rest of knobs (I think it’s the way it works on VC)

    Another thing. I see that the font of the combos is too small and it’s not the font I used for the panel (it is included in the zip file). Did you installed the font?

    #21640

    kwtsh
    Participant

    I’ll have to do a bit more testing with the GUI and will let you know.

    I remember asking about the font and thoughts this wasn’t something that could be fixed. Thanks for that tip. Now the fonts are installed I can enlarge the panel and the fonts enlarge too, making loading patches WAY easier!!!

    #21641

    dasfaker
    Participant

    Cool. I assumed people was installing the included fonts.

    My previous post it’s missing a link!!

    The file is correct and the name too. It’s the way it should be.

    Could this be related? http://ctrlr.org/forums/topic/ctrlr-component-good-to-go/
    Does this happens with the vst, too?

    #21642

    kwtsh
    Participant

    If you recall I’m trying to get multiple tracks in live each with a Ctrlr instance, each configured to use different parts.

    Here’s more detail of the problem I have selecting the outputs in the panel. At the moment I dont have any more analog output options. No matter what output is selected The Virus still outputs on Out 1 L&R.

    For the AU and VST versions on Mac:

    These Panel Outputs all seems correct:

    Output = Off
    Panel’s Message GUI: Multi Part Parameter Output Select Off

    Output = Out 1 L
    Panel’s Message GUI: Multi Part Parameter Output Select Out 1 L

    Output = Out 1 L&R
    Panel’s Message GUI: Multi Part Parameter Output Select Out 1 & 2

    Output = Out 1 R
    Panel’s Message GUI: Multi Part Parameter Output Select Out 1 R

    These Panel Outputs have appear to select different outputs:

    Output = Out 2 L
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 1 L

    Output = Out 2 L&R
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 1 L&R

    Output = Out 2 R
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 1 R

    Output = Out 3 L
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 2 L

    Output = Out 3 L&R
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 2 L&R

    Output = Out 3 R
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 2 R

    Output = USB 1 L
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 3 L

    Output = USB 1 L&R
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 3 L&R

    Output = USB 1 R
    Panel’s Message GUI: Multi Part Parameter Output Select Out USB 3 R

    Then

    Output = USB 2 L
    Panel’s Message GUI: Multi Part Parameter Output Select Out (Nothing More)

    Output = USB 2 L&R
    Panel’s Message GUI: Multi Part Parameter Output Select Out (Nothing More)

    Output = USB 2 R
    Panel’s Message GUI: Multi Part Parameter Output Select Out (Nothing More)

    There is no option in the panel for USB 3 L / L&R / R in the AU or VST version.

    The standalone version allows Out 1 L / L&R / R which appears to select the correct Output, but selecting Out 2 or Out 3 doesn’t appear to select these Outs. But then again I havent placed an override file anywhere to adjust the standalone version.

    • This reply was modified 3 years, 1 month ago by  kwtsh.
    #21644

    kwtsh
    Participant

    Hi again

    So the AU and VST appear identical. Now I’ve turned the Mix of the Phaser up all the GUI elements responded.

    Some aspects of various sections of the panel dont seem to respond to knobs; likely still the problem where we need to figure out how to increase the panels modulators?

    OSC 1 Type: Can change on Virus and hear the resulting difference, not reflected in panel, changing this on the panel doesn’t change the OSC type on the virus, but does send Midi to the Virus
    OSC 3 (I can change these on the virus and hear the difference)
    Unison
    Matrix: Panel reflects how Virus is setup for the patch, changes to the virus can be heard, but not reflected in the panel
    Arp: Turning on the Arp in the panel doesn’t invoke the Arp on the Virus. Turning on the Arp on the virus doesn’t change the panel.
    FX1: Not much other than Chorus seems to work.
    FX2: Delay seems to work, Reverb doesn’t.
    Common: Selecting outputs. Same result as previous post.

    All so tantalisingly close to a wicked Virus synced setup!

    How can we try and figure out the overrides issue?

    #21647

    kwtsh
    Participant

    OMG! I’ve just had a 3.5 Hr Jam, without the virus crashing once and all in Sync!!!! 🙂

    #21654

    dasfaker
    Participant

    Here’s more detail of the problem I have selecting the outputs in the panel. At the moment I dont have any more analog output options. No matter what output is selected The Virus still outputs on Out 1 L&R.

    This is related to the overrides issue.

    But as I don’t have in the Snow so many outs, I don’t know the sysex message needed for each out.
    Could you connect the Virus to a midi monitor and select all outs one by one (in the Virus) to write down which message the Virus sends, and put it here?

    The standalone version allows Out 1 L / L&R / R which appears to select the correct Output, but selecting Out 2 or Out 3 doesn’t appear to select these Outs. But then again I havent placed an override file anywhere to adjust the standalone version.

    The standalone version doesn’t need the overrides file, only the vst.

    If you have the same problems with the standalone version, there must be another issue.
    Can you control fx and arp in the standalone version?

    #21655

    dasfaker
    Participant

    OSC 1 Type: Can change on Virus and hear the resulting difference, not reflected in panel, changing this on the panel doesn’t change the OSC type on the virus, but does send Midi to the Virus
    OSC 3 (I can change these on the virus and hear the difference)
    Unison
    Matrix: Panel reflects how Virus is setup for the patch, changes to the virus can be heard, but not reflected in the panel
    Arp: Turning on the Arp in the panel doesn’t invoke the Arp on the Virus. Turning on the Arp on the virus doesn’t change the panel.
    FX1: Not much other than Chorus seems to work.
    FX2: Delay seems to work, Reverb doesn’t.
    Common: Selecting outputs. Same result as previous post.

    This is not related to .overrides file, and I think I now what it is. Sysex messages aren’t being sent by the panel, only CCs messages are sent.

    1. Be sure MIDI DEVICE ID is set to the same value on the Virus and on the panel (this parameter can’t be changed with a sysex message, so you have to adjust it on both the Virus and the panel).

    2. Select on the panel a different Part and select again on the panel the original Part (if you are on Part 1, for example, select Part 2 and again select Part 1). Now tweak on the Virus OSC1, for example. The panel should react.
    I think a variable is not being activated unless you change Part on the panel. I’m working on a fix, but please test the above.

    • This reply was modified 3 years, 1 month ago by  dasfaker.
    #21663

    dasfaker
    Participant

    I found the problem. The Midi Device ID combo on the Virus panel (but not in the Snow panel) has a 0 value that should not be there, so sysex messages where been transmitted and received incorrectly. I’m uploading a fix right now.

    #21714

    kwtsh
    Participant

    Hey, wow 🙂

    New panel working really sweet, OSC 3, LFO3, Matrix, Arp, Fx all reacting to the Virus!!! Yes!! Thank you!! Will give it a good test tonight 🙂

    Works on Out 1 L&R (TRS). What I love about this is the ability to set my interface at 96Khz with Virus @ 48K rather than 44.1K on USB 🙂 Can’t get it to play on other outs though…

    >>Could you connect the Virus to a midi monitor and select all >>outs one by one (in the Virus) to write down which message the >>Virus sends, and put it here?

    Output = Off

    00 F0 00 20 33 01 00 73 00 2D 00 F7
    Output = Out 1 L
    
00 F0 00 20 33 01 00 73 00 2D 01 F7
    Output = Out 1 L&R

    00 F0 00 20 33 01 00 73 00 2D 02 F7
    Output = Out 1 R
    00 F0 00 20 33 01 00 73 00 2D 03 F7
    Output = Out 2 L
    
00 F0 00 20 33 01 00 73 00 2D 04 F7
    Output = Out 2 L&R
    
00 F0 00 20 33 01 00 73 00 2D 05 F7
    Output = Out 2 R
    
00 F0 00 20 33 01 00 73 00 2D 06 F7
    Output = Out 3 L
    
00 F0 00 20 33 01 00 73 00 2D 07 F7
    Output = Out 3 L&R
    
00 F0 00 20 33 01 00 73 00 2D 08 F7
    Output = Out 3 R
    
00 F0 00 20 33 01 00 73 00 2D 09 F7

    Was able to get this from the Virus’s Surround Menu, but as no USB is plugged maybe it doesn’t show any USB outs?

    Got this from selecting the Out in the panel, from Off to USB 2 R

    [19:23:45:000242]: RAW:[f0 00 20 33 01 00 73 00 2d 07 f7]
    [19:23:45:000243]: RAW:[f0 00 20 33 01 00 73 00 2d 07 f7]
    [19:23:56:000463]: RAW:[f0 00 20 33 01 00 73 00 2d 08 f7]
    [19:23:56:000465]: RAW:[f0 00 20 33 01 00 73 00 2d 08 f7]
    [19:24:01:000199]: RAW:[f0 00 20 33 01 00 73 00 2d 09 f7]
    [19:24:01:000220]: RAW:[f0 00 20 33 01 00 73 00 2d 09 f7]
    [19:24:05:000118]: RAW:[f0 00 20 33 01 00 73 00 2d 0a f7]
    [19:24:05:000119]: RAW:[f0 00 20 33 01 00 73 00 2d 0a f7]
    [19:24:09:000002]: RAW:[f0 00 20 33 01 00 73 00 2d 0b f7]
    [19:24:09:000012]: RAW:[f0 00 20 33 01 00 73 00 2d 0b f7]
    [19:24:17:000551]: RAW:[f0 00 20 33 01 00 73 00 2d 0c f7]
    [19:24:17:000591]: RAW:[f0 00 20 33 01 00 73 00 2d 0c f7]
    [19:24:29:000014]: RAW:[f0 00 20 33 01 00 73 00 2d 0d f7]
    [19:24:29:000015]: RAW:[f0 00 20 33 01 00 73 00 2d 0d f7]
    [19:24:33:000346]: RAW:[f0 00 20 33 01 00 73 00 2d 0e f7]
    [19:24:33:000348]: RAW:[f0 00 20 33 01 00 73 00 2d 0e f7]
    [19:24:36:000265]: RAW:[f0 00 20 33 01 00 73 00 2d 0f f7]
    [19:24:36:000266]: RAW:[f0 00 20 33 01 00 73 00 2d 0f f7]

    Hope this helps delighted with how this is coming together.

    Thanks, J

    • This reply was modified 3 years, 1 month ago by  kwtsh.
    #21716

    kwtsh
    Participant

    PS: Are there any keyboard shortcuts to switch between the tabs of the panel?

    #21717

    dasfaker
    Participant

    Hi Jon

    It’s working, cool!!

    PS: Are there any keyboard shortcuts to switch between the tabs of the panel?

    No, there are no shortcuts, but those buttons are automatable, so in Ableton you can midimap or keymap them.

    Output = Off

    00 F0 00 20 33 01 00 73 00 2D 00 F7
    Output = Out 1 L
    
00 F0 00 20 33 01 00 73 00 2D 01 F7…

    This 00 value at the beginning is very strange, sysex strings must start with F0.

    Got this from selecting the Out in the panel, from Off to USB 2 R

    [19:23:45:000242]: RAW:[f0 00 20 33 01 00 73 00 2d 07 f7]

    Again this is weird, in the panel Off value is
    [f0 00 20 33 01 00 73 00 2d 00 f7], not 07.

    I’ve seen another bug related to the text displayed when you change outs, thats why output selected and output displayed on the panel didn’t matched, but the actual sysex message is correct (I think)

    • This reply was modified 3 years, 1 month ago by  dasfaker.
    #21719

    kwtsh
    Participant

    Here’s Out Off to Out 3 R from the Virus Ti hardware selection of Surround

    [20:13:50:000492]: RAW:[f0 00 20 33 01 00 73 02 2d 00 f7]
    [20:13:55:000049]: RAW:[f0 00 20 33 01 00 73 02 2d 01 f7]
    [20:13:57:000360]: RAW:[f0 00 20 33 01 00 73 02 2d 02 f7]
    [20:13:59:000913]: RAW:[f0 00 20 33 01 00 73 02 2d 03 f7]
    [20:14:02:000411]: RAW:[f0 00 20 33 01 00 73 02 2d 04 f7]
    [20:14:04:000314]: RAW:[f0 00 20 33 01 00 73 02 2d 05 f7]
    [20:14:06:000158]: RAW:[f0 00 20 33 01 00 73 02 2d 06 f7]
    [20:14:07:000249]: RAW:[f0 00 20 33 01 00 73 02 2d 07 f7]
    [20:14:08:000336]: RAW:[f0 00 20 33 01 00 73 02 2d 08 f7]
    [20:14:08:000865]: RAW:[f0 00 20 33 01 00 73 02 2d 09 f7]

    and from the panel’s Outs:

    [20:15:34:000991]: RAW:[f0 00 20 33 01 00 73 00 2d 00 f7]
    [20:15:34:000993]: RAW:[f0 00 20 33 01 00 73 00 2d 00 f7]
    [20:15:38:000553]: RAW:[f0 00 20 33 01 00 73 00 2d 01 f7]
    [20:15:38:000566]: RAW:[f0 00 20 33 01 00 73 00 2d 01 f7]
    [20:15:44:000369]: RAW:[f0 00 20 33 01 00 73 00 2d 02 f7]
    [20:15:44:000400]: RAW:[f0 00 20 33 01 00 73 00 2d 02 f7]
    [20:15:46:000101]: RAW:[f0 00 20 33 01 00 73 00 2d 03 f7]
    [20:15:46:000109]: RAW:[f0 00 20 33 01 00 73 00 2d 03 f7]
    [20:15:47:000593]: RAW:[f0 00 20 33 01 00 73 00 2d 04 f7]
    [20:15:47:000618]: RAW:[f0 00 20 33 01 00 73 00 2d 04 f7]
    [20:15:49:000742]: RAW:[f0 00 20 33 01 00 73 00 2d 05 f7]
    [20:15:49:000744]: RAW:[f0 00 20 33 01 00 73 00 2d 05 f7]
    [20:15:51:000098]: RAW:[f0 00 20 33 01 00 73 00 2d 06 f7]
    [20:15:51:000136]: RAW:[f0 00 20 33 01 00 73 00 2d 06 f7]
    [20:15:53:000855]: RAW:[f0 00 20 33 01 00 73 00 2d 07 f7]
    [20:15:53:000856]: RAW:[f0 00 20 33 01 00 73 00 2d 07 f7]
    [20:15:56:000348]: RAW:[f0 00 20 33 01 00 73 00 2d 08 f7]
    [20:15:56:000349]: RAW:[f0 00 20 33 01 00 73 00 2d 08 f7]
    [20:15:58:000606]: RAW:[f0 00 20 33 01 00 73 00 2d 09 f7]
    [20:15:58:000615]: RAW:[f0 00 20 33 01 00 73 00 2d 09 f7]
    [20:16:01:000390]: RAW:[f0 00 20 33 01 00 73 00 2d 0a f7]
    [20:16:01:000392]: RAW:[f0 00 20 33 01 00 73 00 2d 0a f7]
    [20:16:04:000233]: RAW:[f0 00 20 33 01 00 73 00 2d 0b f7]
    [20:16:04:000258]: RAW:[f0 00 20 33 01 00 73 00 2d 0b f7]
    [20:16:06:000610]: RAW:[f0 00 20 33 01 00 73 00 2d 0c f7]
    [20:16:06:000618]: RAW:[f0 00 20 33 01 00 73 00 2d 0c f7]
    [20:16:09:000548]: RAW:[f0 00 20 33 01 00 73 00 2d 0d f7]
    [20:16:09:000549]: RAW:[f0 00 20 33 01 00 73 00 2d 0d f7]
    [20:16:11:000928]: RAW:[f0 00 20 33 01 00 73 00 2d 0e f7]
    [20:16:11:000929]: RAW:[f0 00 20 33 01 00 73 00 2d 0e f7]
    [20:16:14:000078]: RAW:[f0 00 20 33 01 00 73 00 2d 0f f7]
    [20:16:14:000121]: RAW:[f0 00 20 33 01 00 73 00 2d 0f f7]

    Hope that helps?

    I was using two different midi monitors and the 00 at the beginning was just an intended copy paste. Does this make more sense?

    I tried Midi mapping in Live (cmd-m) and when selecting the different tabs of the panel but couldn’t get the Live to recognise the tabs using Configure or Midi Map. I’d like to map my computer keyboard to the various panel tabs labels eg

    O – OSC
    A – Arp
    F – FX1
    X – FX2 etc

    That would be super quick for live performance

    #21721

    dasfaker
    Participant

    The only difference in the sysex that I can see is that from the Virus, [f0 00 20 33 01 00 73 02 2d 00 f7] this 02 value is for Part 3, and from the panel [f0 00 20 33 01 00 73 00 2d 00 f7] is for Part 1. The rest of the message is the same. Are you operating on different parts?

    About midimapping, you have to make the buttons automatable (remember the triangle button on Ctrlr device, then click configure button and finally click the tab buttons). Now those buttons can be midimapped or keymapped.

    EDIT: Actually I removed this option because combo buttons in Ctrlr don’t work too fine. Midimapping or keymapping them do change the tab, but they don’t turn off when needed (it’s only a visual bug): Anyway I’ll add this function in the next release.

    • This reply was modified 3 years, 1 month ago by  dasfaker.
    #21766

    dasfaker
    Participant

    The last two posts in this thread are missing.

Viewing 20 posts - 1 through 20 (of 45 total)

You must be logged in to reply to this topic.

Comments are closed.