Home Forums General Using Ctrlr midi reception

This topic contains 0 replies, has 1 voice, and was last updated by zeoka zeoka 3 years ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #21007
    zeoka
    zeoka
    Participant

    Hi
    I really don’t know how this can be fixed….

    Problem with Ctrlr midi reception
    I use z”x” formula (roland “128- ((bytes to count “x”)%128)”) in the sysex editor

    -Sample mods have k0 and k1 and z5
    -the 6 “sample nb” (val: 0 to 1023) mods in part/12 phrases per part
    have MS LS and z6
    -the part and phrase data share some mods including “sample nb” so I change sysex formula on the fly via LUA

    From what I see on the midi monitor all is perfect , ctrlr sends perfect

    but ctrlr modulators don’t receive mainly the midi messages
    and even it takes the midi message of the device and change to mods !!
    EX : a volume mod has f0 41 10 00 1d 12 11 00 00 04 xx z5 f7 in “normal mode” in ctrlr.
    the sampler sends f0 41 10 00 1d 12 11 00 00 04 xx z5 f7 ctrlr receives normally.

    then I switch to “phrase mode” , then my mod sends f0 41 10 00 1d 12 12 00 00 02 xx z5 f7 the sampler receive normally.
    So I tweak on the sampler the first volume param message f0 41 10 00 1d 12 11 00 00 04 xx z5 f7..

    and what my surprise when I saw the sampler tweak moves the ctrlr mod and now the mod has f0 41 10 00 1d 12 11 00 00 04 xx z5 f7 like the sampler

    Any explanation ?

    • This topic was modified 3 years ago by zeoka zeoka.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

Comments are closed.