Home Forums General Programming Preventing program change MIDI loop with program change modulator

This topic contains 1 reply, has 1 voice, and was last updated by opuswerk opuswerk 3 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #21309
    opuswerk
    opuswerk
    Participant

    Hello fellow CTRLR’s,

    While building the MKS70/JX10 panel, I’ve encountered a behaviour I simply can’t get my head around. When changing a patch on the MKS70, it sends a sysex patch dump. I use the data in this one to update all the parameters of the panel. So far so good (despite me not really understanding which byte is linked to which param, but that is getting better and should be finished soon)

    However, I have included a Modulator that allows to send program change messages. This one is a uiListBox with the 64 different patches written down in a list. It sends program change messages just fine. However, when it receives a patch change from the synth (if i change the patch manually on the hardware itself), it sends back a program change message, thus, I end up with the synth sending 2 patch dumps.

    When I change the program on the synth, I receive this message:

    [12:24:32:000965]: RAW:[f0 41 34 00 24 30 01 16 00 f7]
    [12:24:32:000986]: RAW:[f0 41 35 00 24 30 01 20 20 42 4f 57 45 44 20 53 54 52 49 4e 47 53 20 20 20 41 50 27 26 00 00 00 5d 19 2d 00 36 00 00 4e 01 1a 00 01 00 36 00 00 4e 01 18 00 01 00 7f 00 03 01 00 01 f7]
    [12:24:32:000989]: RAW:[f0 41 34 00 24 20 01 36 00 f7]
    [12:24:33:000013]: RAW:[f0 41 35 00 24 20 01 41 52 43 4f 20 53 54 52 4e 47 20 34 60 42 07 00 20 60 00 46 46 00 02 7f 7f 7f 00 60 7f 7f 7f 00 60 00 49 00 00 1a 61 60 60 6d 40 25 40 39 64 00 27 00 26 20 40 4e 46 33 40 7f 40 f7]
    [12:24:33:000016]: RAW:[f0 41 34 00 24 20 02 36 00 f7]
    [12:24:33:000040]: RAW:[f0 41 35 00 24 20 02 41 52 43 4f 20 53 54 52 4e 47 20 34 60 42 07 00 20 60 00 46 46 00 02 7f 7f 7f 00 60 7f 7f 7f 00 60 00 49 00 00 1a 61 60 60 6d 40 25 40 39 64 00 27 00 26 20 40 4e 46 33 40 7f 40 f7]
    

    which is then quickly followed by this one:

    [12:24:33:000041]: RAW:[c0 16]
    [12:24:33:000249]: RAW:[f0 41 34 00 24 30 01 16 00 f7]
    [12:24:33:000270]: RAW:[f0 41 35 00 24 30 01 20 20 42 4f 57 45 44 20 53 54 52 49 4e 47 53 20 20 20 41 50 27 26 00 00 00 5d 19 2d 00 36 00 00 4e 01 1a 00 01 00 36 00 00 4e 01 18 00 01 00 7f 00 03 01 00 01 f7]
    [12:24:33:000274]: RAW:[f0 41 34 00 24 20 01 36 00 f7]
    [12:24:33:000297]: RAW:[f0 41 35 00 24 20 01 41 52 43 4f 20 53 54 52 4e 47 20 34 60 42 07 00 20 60 00 46 46 00 02 7f 7f 7f 00 60 7f 7f 7f 00 60 00 49 00 00 1a 61 60 60 6d 40 25 40 39 64 00 27 00 26 20 40 4e 46 33 40 7f 40 f7]
    [12:24:33:000301]: RAW:[f0 41 34 00 24 20 02 36 00 f7]
    [12:24:33:000324]: RAW:[f0 41 35 00 24 20 02 41 52 43 4f 20 53 54 52 4e 47 20 34 60 42 07 00 20 60 00 46 46 00 02 7f 7f 7f 00 60 7f 7f 7f 00 60 00 49 00 00 1a 61 60 60 6d 40 25 40 39 64 00 27 00 26 20 40 4e 46 33 40 7f 40 f7]
    

    As you can see, the first message is a sysex program change message, sent by the uiListBox with my program list.

    I was thinking of disabling the uiListBox on MIDI receive. But I haven’t yet found a proper way of doing so. I’m sure i’m missing something obvious, but i’ve spent too much time now trying to find for a solution, so i’m asking for your help.

    • This topic was modified 3 years, 4 months ago by opuswerk opuswerk.

    http://opuswerk.tumblr.com
    www.soundcloud.com/opuswerk
    www.facebook.com/opuswerk

    #21317
    opuswerk
    opuswerk
    Participant

    I think I found my mistake, I had setup both the controller and the output of the panel to go to the same MIDI destination. After setting the Controller to none, it works fine.

    I believe someone else mentioned that in another thread. So I’m sorry if this is a repeat of another thread. Feel free to delete this one if needed 🙂

    http://opuswerk.tumblr.com
    www.soundcloud.com/opuswerk
    www.facebook.com/opuswerk

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.