Roland MKS-50 Advanced

Home Forums General Panels, Components, Macros Roland MKS-50 Advanced

This topic contains 64 replies, has 33 voices, and was last updated by Possemo Possemo 2 months, 3 weeks ago.

Viewing 20 posts - 21 through 40 (of 65 total)
  • Author
    Posts
  • #13541

    AnotherSwede
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hi Bomma72
    Some pretty cool stuff going on, the panel looks hot. Don’t own a
    Roland MKS-50 yet but soon and if it would be possible to “control the sliders via a midi controller” that would be sick. People wouldn’t pay $500 for a real PG 300.
    KEEP UP THE GOOD WORK!

    #13851
    bluelion
    bluelion
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    Hey there,

    I really appreciate the work you put into this panel. I’m new to CTRLR but I love the idea of it. That said, I’m not much of a programmer, but I try to see if I can find out stuff on my own before I post on forums. That said…

    I tried opening up this panel in Live 9.0.6 in hopes to use the Configure option to use automation from Ableton to control the parameters of the panel/my Alpha Juno-1. Interestingly enough, three parameters are recognized by Ableton as “configurable”: LfoDly, LfoRate, and DcoLfo. When I use the sliders of the configured parameters in Ableton it animates the mapped knobs and relays the appropriate messages to my Juno. So, after spending about a half an hour with a new program, trying to spot the difference in WHY this is happening with these three knobs, I’ve come to the end of myself.

    So, señor panel maker sir, do you have any idea why this might be happening? Or rather, if it’s working effectively for these three parameters, what do I need to investigate or update in the downloaded panel I’m using so I can configure the rest of the sliders in the MKS-50 panel?

    Thanks for your input,
    bluelion

    Attachments:
    You must be logged in to view attached files.
    #13859

    Bomma72
    Participant
    • Topics: 20
    • Replies: 68
    • Total: 88

    Hi truthfully I am not sure how to do this. I believe it has something to do with the VST Index but I am not positive. You will have to so some searching on this forum under how to control Ctrl with external cc#. I am pretty sure you have to set up each control on the panel to match the hardware’s cc#s. Sorry I can’t be of more help.

    #13860
    atom
    atom
    Moderator
    • Topics: 156
    • Replies: 2940
    • Total: 3096
    • ★★★★★

    I changed the VST indexes and all parameters should be visible inside Ableton Live. I’m attaching it below, but if the author wishes for it to be removed, please let me know and i will. This is not my (excellent) work.

    Attachments:
    You must be logged in to view attached files.
    #13872
    bluelion
    bluelion
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    Wowzers. Thanks for this, Atom! This is going to be the most productive weekend EVERRRRRRRRRR.

    Attachments:
    You must be logged in to view attached files.
    #13875
    bluelion
    bluelion
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    Just to follow up with this improvement…

    I experimented with the plug-in in Ableton, and I found that Ableton will not save the plug-in window’s configuration parameters if you click the floppy disk icon and save the plug-in’s state. It does save the preset within Ableton in the User Library, which is fantastic.

    The easy way to be able to have the same configured parameters included in the plug-in window is to create a set in Ableton with the CRTRL plug-in on a channel. Click the configure button and click away on the panel’s sliders to include them in the plug-in window. Save the project. Now anytime that you want to pull out the plug-in window with all of the automation-enabled parameters in the plug-in window, just find the set you created with the plug-in, and drag’n’drop it into the current project. It should bring the plug-in window just as you saved it in its original set, with all of the parameters “configured” and ready to go!

    I super love CTRLR. I’m going to spend some time figuring this thing out and see if I can create a panel for my Roland D-110.

    #13881

    Bomma72
    Participant
    • Topics: 20
    • Replies: 68
    • Total: 88

    Thanks, Atom, not sure what I did wrong if anything. Hey if you want to add this panel to the downloads section I would be cool with that. Glad you guys like the panel.

    #17691

    mydni
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    Hi,
    I’ve just bought a Juno 2 and found this fantastic ctrl panel, works really great.
    Two issues : the portamento section (cc 65 on/off & 4 time) isn’t working for me, same for the chord function (and I know it’s a bit different from the MKS50).
    I’m not a programmer, can someone help ?
    Thanks again for this great great panel.
    Greg

    #17695

    mydni
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    So I think the portamento is only responding to midi cc (65, 4).
    On the midi tab of the panel mode, I’ve tried to change the midi message type to cc for the on/off switch (65) and the portamento time slider (4) but the Juno isn’t receiving anything.
    Please help.
    Thks
    Greg

    #17831

    mydni
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    Bump, anyone please ?
    I just want to make those two controllers (portamento on/off, time) on the panel to send cc to the Juno 2, not sysex. when I try in panel mode, it doesn’t work and perhaps this is not possible.
    Thanks for your help,
    Greg

    #19318
    Synthetech
    Synthetech
    Participant
    • Topics: 13
    • Replies: 70
    • Total: 83

    *** PLEASE USE THE THIRD ZIP FILE FURTHER DOWN IN THIS THREAD ****

    Bonus here K3 in progress, hopefully done in a few weeks.

    K3

    *** PLEASE USE THE THIRD ZIP FILE FURTHER DOWN IN THIS THREAD ****

    what ever happened to this kawai K3 panel??
    this thing looks great!

    I tried to msg Bomma72, but i cannot find a way to do so.

    hope this is a real panel I can get for my K3.
    I just spent two days working up my own, but not near as nice as this one looks.. hoping to save myself the trouble of doing controls that gave me troubles..
    ThanKS!

    #20419

    TomRamen
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Just got this panel to work with my MKS-50, so far I am having zero issues with it. Im rather new to ctrlr and it took me quite a while to set it up correctly, but once I did, I was and still am in Juno programming heaven!

    Thank you for making this way more effective than the pg300 ever was!

    #20674

    MCBIV
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    Thanks a bunch…

    #21116

    meta5000
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hello, very, very cool Plug. My only Problem is: it crashes Ableton 9.1, no problems under Live 8.4. Any ideas? Regards Felix

    #22245

    ishkabob
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Thanks, this works pretty well on my Alpha Juno 1. One weird caveat about this seems to be that the Alpha Juno 1 only transmits its patch data (upon program change initiated on the front panel of the synth) when Midi Local is set to ON. I’m not sure why that is, but when simply monitoring the raw midi messages I discovered this. Cheers!

    #25342

    lejuan
    Participant
    • Topics: 1
    • Replies: 2
    • Total: 3

    hello, awesome panel, ive just got a mks50 but im getting a crash when double click the tone button to receive the values from the synth
    ———————————————————————-
    Callback error: setPatch

    lua runtime error

    At line [-1]: [C]
    What: C
    Namewhat: field
    Name: format
    Error message: [string “setPatch = function(midiMessage)…”]:100:bad argument #3 to ‘format’ (string expected, go nil)

    Method disabled

    ——————————————————-

    im using ableton live 9.1 and osx

    any help??? thanks!!!

    J

    #25862

    lejuan
    Participant
    • Topics: 1
    • Replies: 2
    • Total: 3

    update: problem solved seemed like a problem with some characters in patches names, also, it seems like it has to be the same name in bank A and B

    #27804

    mkpiet
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hello,

    I’m in trouble because I’ve never managed to control my alpha juno from ableton with this ctrlr pannel,

    wich configuration must I make in ctrlr and in ableton to have this working ?

    When I try to put my sound card as midi output in ctrl it always says ” Warning opendeviced failed to open the device” (as in printscreen below)

    I know Live does’nt accept sysex so need I midi Yoke or another soft to run it ???

    I’m on win 7 64 bit (but I also tried on win xp 32 bit)

    Attachments:
    You must be logged in to view attached files.
    #28472

    NoNameNeeded
    Participant
    • Topics: 2
    • Replies: 11
    • Total: 13

    I understand that I can save a snapshot of the momentary position of all sliders etc but I wonder if it’s possible to save these snapshots like presets in a list (in the computer).?
    Furthermore the plugin doesn’t work at all.
    The dll file ctrlr….dll (or the like) sits in the VST plugins folder but isn’t recognized by Cubase at all.
    Not even in the plugin information window (where it should be at least listed).
    I use Cubase 5.5 which isn’t the most recent version but it’s still a VST3 host so I guess it should be fine.

    #48552

    analogPOWER
    Participant
    • Topics: 2
    • Replies: 1
    • Total: 3

    Help needed please.

    Hello, I am using this CTRLR panel in Windows 7 64b 16gig ram, RMEinterface MOTUmidi DAW: Ableton Live 9.1.7

    I get the panel to kind of communicate, I can use the configure button on the Ableton plugin instance to control the parameters of the patch/synth.(automation in Ableton)

    I can move a slider on the panel and it preforms its function on the Juno.

    issues I am having:
    the panel interface settings for each patch stays the same when I change the patches on the Juno or the panel or Ableton (program change int he midi section)

    The midi part / clip (piano roll) when I press a keyboard key plays sound but no indication in the midi clip what key was pressed, usually the key on the piano roll in Albeton lites red.

    The envelope graphic window on the panel is blank so is the patch name.

    I have the unit in local mode off ; omni off.

    I am thinking I set the midi ports up funny, and I am using a separate interface for the CTRLR panel because there was some conflict with Ableton hogging the midi ports.

    If anyone could assist here Id be happy. Thank you.

    -aP

Viewing 20 posts - 21 through 40 (of 65 total)

You must be logged in to reply to this topic.

There is currently 1 user and 29 guests online
Possemo
Forum Statistics
Threads: 2,157, Posts: 15,212, Members: 16,564
Most users ever online was 9 on October 14, 2018 10:42 am
Do NOT follow this link or you will be banned from the site!