Roland MKS-50 Advanced

Home Forums General Panels, Components, Macros Roland MKS-50 Advanced

This topic contains 58 replies, has 30 voices, and was last updated by  factorydiscipline 1 month, 2 weeks ago.

Viewing 19 posts - 41 through 59 (of 59 total)
  • Author
    Posts
  • #60849

    bjornbjorn2
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    hi
    did u ever finish the K3 editor ?

    #69827

    brunello
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hi Bomma,first of all thanks for your nice and very useful programmer.I’m currently using it with Ableton Live 9 and eveything works fine except for the fact that alpha juno plays sounds even when I play different instruments with different channels in any project. EG: When i play the alpha juno by your au programmer on his midi channel i only listen to, it but if i change track and i play any ableton instrument the alpha juno overdub it like the local control were ON even if it’s setted off. Where
    I’m wrong?
    Thanks
    Bruno

    #70087

    Syonix
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    *** PLEASE USE THE THIRD ZIP FILE FURTHER DOWN IN THIS THREAD ****

    Bonus here K3 in progress, hopefully done in a few weeks.

    K3

    *** PLEASE USE THE THIRD ZIP FILE FURTHER DOWN IN THIS THREAD ****

    Did you ever complete your K3 editor? I have a K3M and your editor looks like it would be very good for editing and managing my K3. I hope to hear from you, thanks.

    #72447

    redcarrera4
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    If you are getting errors in CTRLR when trying to access a midi interface IN or OUT, the solution in Ableton is to disable the midi interface (in preferences, turn OFF Track and Remote in the IN and OUT of the interface). By turning it off in the Live preferences, it should be able to let CTRLR use the interface.
    This pretty much fixed it for me.

    • This reply was modified 10 months, 3 weeks ago by  redcarrera4.
    #72449

    redcarrera4
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    Hello,

    I’m in trouble because I’ve never managed to control my alpha juno from ableton with this ctrlr pannel,

    wich configuration must I make in ctrlr and in ableton to have this working ?

    When I try to put my sound card as midi output in ctrl it always says ” Warning opendeviced failed to open the device” (as in printscreen below)

    I know Live does’nt accept sysex so need I midi Yoke or another soft to run it ???

    I’m on win 7 64 bit (but I also tried on win xp 32 bit)

    If you are getting errors in CTRLR when trying to access a midi interface IN or OUT, the solution in Ableton is to disable the midi interface (in preferences, turn OFF Track and Remote in the IN and OUT of the interface). By turning it off in the Live preferences, it should be able to let CTRLR use the interface.
    This pretty much fixed it for me.

    #72481

    m.tarenskeen
    Participant
    • Topics: 25
    • Replies: 92
    • Total: 117
    • ★★

    Hi

    I don’t own any MKS-50 or K3 but your panels did attract my attention because the graphics really LOOK great. Beautiful layout, choice of colors, buttons, and sliders! What software, outside Ctrlr, did you use to create the graphics? Did you design everything yourself or did you use existing collections of buttons and sliders?

    #72482

    m.tarenskeen
    Participant
    • Topics: 25
    • Replies: 92
    • Total: 117
    • ★★

    Hi

    I don’t own any MKS-50 or K3 but your panels did attract my attention because the graphics really LOOK great. Beautiful layout, choice of colors, buttons, and sliders! What software, outside Ctrlr, did you use to create the graphics? Did you design everything yourself or did you use existing collections of buttons and sliders?

    #72483

    m.tarenskeen
    Participant
    • Topics: 25
    • Replies: 92
    • Total: 117
    • ★★

    Sorry, same message twice 🙂
    How do I remove a message from here?

    #72562

    Arnoid303
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    Hi,
    I’ve just bought a Juno 2 and found this fantastic ctrl panel, works really great.
    Two issues : the portamento section (cc 65 on/off & 4 time) isn’t working for me, same for the chord function (and I know it’s a bit different from the MKS50).
    I’m not a programmer, can someone help ?
    Thanks again for this great great panel.
    Greg

    Did you find a solution for this problem ?

    I experience the same with my alpha juno… The portamento switch on the mks-50 panel is not working.

    The panel is also only working on midichannel 1 somebody knows how fix this so you can select one between 1-16 ?

    • This reply was modified 9 months, 4 weeks ago by  Arnoid303.
    • This reply was modified 9 months, 4 weeks ago by  Arnoid303.
    #72579

    Arnoid303
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    I was able to fix portamento on-off knob and the portamento time slider

    In panel mode just change it from sysex to cc
    And control number to 65 for portamento and 5 for portamento slider

    Also change max value from 1 to 127 for the portamento on-off knob

    • This reply was modified 9 months, 4 weeks ago by  Arnoid303.
    #72936

    goolana
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hello Atom,

    You made the mks50 vst panel for Ableton. Iam struggling to setup the sliders to midicc. I’ve read that this is only possible in i.e. Cubase with ctrlr as a plugin.

    the panel is working great with sysex to the juno2. I also have the real pg-300 but it would be great to use the juno with automation in i.e. Cubase.

    What is the setup in Cubase. Can I use quick controlls ?

    Thank you and keep up the good work

    Regards Aart

    #72937

    arise
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Help needed please.
    issues I am having:
    the panel interface settings for each patch stays the same when I change the patches on the Juno or the panel or Ableton (program change int he midi section)

    -aP

    Same issue for me

    #72938

    human fly
    Participant
    • Topics: 121
    • Replies: 1023
    • Total: 1144
    • ★★★★

    could be the panel has a problem receiving 2way communication.
    seems to be a tricky bit of Ctrlr to master, so it may not
    have been completely dealt with. in which case disable
    midi in to Ctrlr and just use it as controls to send
    sysex messages with. haven’t myself looked at the under the
    hood stuff or used that panel.

    edit: just had a look at it, seems there’s something there
    for that, so best try to get hold of layzer.

    #82729

    fish62858
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    hi all… new to this thread group

    i downloaded the mks50 controller but i must be missing something…

    i was under the impression it was stand alone software and i wanted to open it up and see what it looks like… i currently do not have the mks50 connected to the computer (it is in a different place than where i am now) but my windows 10 laptop cannot open a “panel” file so i don’t really know what to do…

    i want to get the mks50 to produce a low, thick bass sound that i can tirgger with my elka pm 13 midi pedals, but using the front panel controls i have not been happy with what i’ve done so far… i want to shake the building when i step on a low D

    any help would be appreciated by this newbie

    #82732

    human fly
    Participant
    • Topics: 121
    • Replies: 1023
    • Total: 1144
    • ★★★★

    install Ctrlr. you can then export a ‘restricted instance’
    as an exe standalone. alternatively, if you put the Ctrlr.dll
    in your vst plugins folder, you can open the panel there, and
    run it. you can then, if you want, export a plugin instance
    and run it as a plugin.(if memory serves)
    nb: Ctrlr can run as 32 or 64bit, so whichever you need.

    #82733

    fish62858
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    ah… knew i had missed something… thank you

    so now, connect laptop to mks50 via usb to midi and program away?

    #82745

    human fly
    Participant
    • Topics: 121
    • Replies: 1023
    • Total: 1144
    • ★★★★

    hopefully – i’ve never tried this panel. remember to set up
    midi in/out – and you need it connected both ways of course.
    someone said earlier they weren’t getting panel updating,
    so i don’tknow about that, see if you can get that to work.

    #82748

    fish62858
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    thanks for the assist!

    #83451

    factorydiscipline
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hey, thanks for this editor.

    I am having some problem that I believe is on my end and nothing to do with a glitch with the editor.

    Basically after following your instructions I can only do a few things:
    1. My MKS-50 will send the parameters to the editor (when I hit tone with midi lock on)
    2. Through the editor I am able to change between presets.

    That’s it however. If I try to move any of the sliders no changes in sound occur. I must be missing something here because I also downloaded Alphabase and had the same exact issue. Is there some setting I’m missing? Memory protection is off.

    Thanks

    EDIT:
    I’ve resolved my issue: Turns out it’s my USB to MIDI cable. I have like the cheapest one offered on Amazon and it doesn’t support sysex which is how the MKS-50 and Alpha Juno receive data. I’ll leave this up so that others that might run into the issue will have a reference.

    EDIT2:
    In case you have a cheap USB to MIDI cable like I do, you don’t need to bother buying a more expensive cable. The issue is that the firmware of that the cable provides is not (on its own) capable of processing the amount of data sysex sends. In order to mitigate this issue, download MIDIOX, reroute the midi going from CTRLR to MIDIOX and the MIDIOX going out. Then in MIDIOX limit the amount of data going out (through configuring buffers I believe). I played with the bytes allowed until I got this to work. Goodluck!

Viewing 19 posts - 41 through 59 (of 59 total)

You must be logged in to reply to this topic.

There is currently 0 users and 18 guests online
No users are currently active
Forum Statistics
Threads: 2,120, Posts: 14,901, Members: 8,720
Most users ever online was 5 on March 28, 2018 6:11 pm
Do NOT follow this link or you will be banned from the site!