Home Forums General Using Ctrlr Roland MKS80 – Having issues sending the Parameter value

This topic contains 1 reply, has 2 voices, and was last updated by opuswerk opuswerk 3 years, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #15523

    csmitty
    Participant

    hi,

    i have a Roland MKS-80 and managed to send Sysex to the MKS but I am having trouble sending the Parameter Value.

    The Sysex command is fine (I have a working MKS Programmer as Logic Environment which I use to compare but did not programmed myself), it’s just the Parameter Value that is not send or not send for the whole range (e.g. 0-100).

    Here is my Sysex test command (the parameter in bold):

    F0 41 36 00 20 30 01 02 00 F7
    -> only value 0 is sent, however I have set the minimum value to 0 and the maximum value to 100 within the “Component” tab of Ctrl

    It should be just a simple thing that I have overlooked (this is my first time ever playing with Sysex and Ctrl).

    Please help so I can share the final MKS Programmer 🙂

    Enclosed is my MKS Test Panel.

    Thanks!

    Attachments:
    You must be logged in to view attached files.
    #15933
    opuswerk
    opuswerk
    Participant

    You need to replace the 00 by xx z4. Z4 is the checksum Atom created for all the Roland gear, so i suspect this would help you there.

    Also make sure all your Sysex command is either all in caps or all in lowercase. While working on a panel for the MKS-70, I had issues when mixing upper and lower cases, so i decided to use lowercases only and it’s now working. Unfortunately the synth doesn’t update the Tone parameter values i’m sending it. It’s as if they need a validation of some sort.

    http://opuswerk.tumblr.com
    www.soundcloud.com/opuswerk
    www.facebook.com/opuswerk

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Comments are closed.