Home Forums General Programming uiImageButton Resource Disappears

This topic contains 8 replies, has 3 voices, and was last updated by lfo2vco lfo2vco 3 years, 9 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14241
    lfo2vco
    lfo2vco
    Participant

    Hi, I have a problem with an image resource that disappears when I export an Instance of my panel.

    The image is an RGB png file at 72dpi, I have imported it into the Resources window and linked it to a uiImageButton via the Image Resource Menu. The image appears to be fine in the standalone Ctrlr environment, but also disappears if copy the panel to another computer.

    I am using Ctrlr revision 1547, on an Intel Mac running OS X 10.7.5, the image was created in Photoshop CS 3

    #14245
    msepsis
    msepsis
    Participant

    what file type is the resource? I’ve seen this a few times within ctrlr standalone itself running ctrlr 1590 on a mac, I’ve only seen it with jpgs but for the most part that’s all I’ve been using in my most recent areas of panel development.. I haven’t looked yet to see what happens when I export (cringe) I hope this works ok if it doesnt but I find a work around I’ll repost here.

    When the image “disappears” it literally is gone from the resource list, so I have to reimport it again. Seems as if things work ok then after re-importing, then saving and closing the panel then re-opening it, even on a different machine. I’m saving the panel as a bpanelz (with resources).

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #14248
    atom
    atom
    Moderator

    I think that since 1547 i re-worked some of the resource manager stuff, so you might need to update to get that fixed.

    #14250
    lfo2vco
    lfo2vco
    Participant

    I was going to update to sort a uiLabel issue, but I fixed that with a workaround function in my init method.

    So Atom I guess 1590 is the latest one to try.

    #14265
    lfo2vco
    lfo2vco
    Participant

    OK, I downloaded 1590 for Mac.

    I made a new png, Opened my panel in 1590, deleted the old resource, unlinked the image in the unButton. I then reimported the png resource and relinked the image to the button.

    I saved the panel as a restricted Instance, on opening the Instance the image was still not there.

    Atom or Msepsis can you recommend exactly what png / jpg specification is know to work best with Ctrlr. Maybe I am not saving the png correctly.

    #14267
    atom
    atom
    Moderator

    The format of the image will have no impact on that, i will check that soon.

    #14268
    lfo2vco
    lfo2vco
    Participant

    Cheers Atom.

    #14269
    atom
    atom
    Moderator

    Also try removing the panel specific settings, they will be in a special folder in the home directory somewhere in Library/Preferences, a folder will be named as the panel name, just remove it and re-open the exported instance.

    #14273
    lfo2vco
    lfo2vco
    Participant

    Yep that did it Atom, exactly in that order. I made a new Instance, once again image was missing. So I quit it, found the folder in Library/Preferences trashed it. Relaunched the Instance an hey presto it was there.

    Excellent cheers : )

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed.