Reply To: Build Ctrlr on Windows 10 and others

Home Forums Development Other stuff Build Ctrlr on Windows 10 and others Reply To: Build Ctrlr on Windows 10 and others

#120128
Tedjuh
Participant
  • Topics: 9
  • Replies: 97
  • Total: 106
  • ★★

Small success here. Managed to debug (Yes, debug) the standalone version of Ctrlr from 29-03-2016. The release or nightly release throws a bunch of errors that I know how to solve but didn’t get to yet.

Steps taken:
— Install a very legal version of Visual Studio 2010 (cough)
(If interested, pm me Goodweather)

— Download the Ctrlr Repository from said date.

— Extract the boost folder to the Boost folder. Folders should look like:
— ../Boost/boost/(all boost files)

— Download Juce (from the Juce Github) Version 3.2.0.
It’s the last version I could find that had the Introjucer in it. It got replaced by Projucer after that version. But Introjucer is needed for the 5.3(.201) version.

— Copy the files from the Juce commit to the Ctrlr Commit. Except for the Modules folder.
— Build the Introjucer. Find the Solution file in the Juce/Extras/IntroJucer/Builds Folder.

You can try to debug it now. But it will probably throw a lot of errors, something about pre-compiled headers and stuff and some /Ym switch. If it does, do the following:

-In the Solution Explorer in Visual Studio, go to:
Ctrlr Standalone/Core/stdafx.cpp
— Right-click and go to properties.
— Go to: Configuration Properties/ C/C++ /Precompiled Header
— Change Precompiled Header to “Create (/YC)”. It’s probably blank. Just click the blank box.
–Also go to Command Line (also under C/C++). Make sure “inherit from project or project defaults” is checked.

Last but not least:

-In the solution explorer in Visual Studio, right-click the “Ctrlr Standalone” and click properties.
-Go to: Configuration Properties/ C/C++ / Command Line
-At the bottom where it says “Additional Options” change /Zm2000 into Zm200. Other values might work, didn’t bother to try.

If it throws an error somewhere about CtrlrRevision.h not found, change “CtrlrRevision.Template” in the same folder as the stdafx.cpp file to CtrlrRevision.h. Or, while your at it, change the build and revision name and stuff into something like I did. See screenshot.

G’luck.

Attachments:
You must be logged in to view attached files.
Ctrlr