10.5 versions

Home Forums Platform Specific OSX 10.5 versions

  • This topic has 10 replies, 6 voices, and was last updated 9 years ago by atom.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #557
    credo
    Participant
    • Topics: 1
    • Replies: 1
    • Total: 2

    Hi there I am completely new here. Trying to understand what this thing is :oops: and how I can control my Blofeld with it.
    However, the latest builds for OS X doesnt work on my mac adn I guess this is because the OS is too old.
    Are there older versions that could be run on 10.5.8? Where do I find them?

    Thanks
    C

    #3875
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I’m doing my builds on 10.6.something it might be possible to run it on 10.5 i think but i’m not sure. There are no "old" builds only those on the Downloads page.

    #3876
    credo
    Participant
    • Topics: 1
    • Replies: 1
    • Total: 2

    The .app can not be run.
    Dont know what this program does. Can it be done in any other way?
    Where should the panel be placed? How does it all work together?

    #3877
    jwojwo
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    Hey,
    It definitely doesn’t work on 10.5 – I’m running 10.5 too and neither the .app nor the .au will operate.
    Is there any possibility of getting hold of an old build? Desperate to start tweaking my DSI evolver!

    No worries if not, but it’d be much appreciated

    Jeremy Warmsley / Summer Camp
    facebook.com/summercampmusic

    #3878
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Well i can try to do a 10.5 compatible build but i have no idea how will it work on 10.7 and whatever the new Mountain Lion version number will be, i’ll consider that doing the next nightly, so when it shows up try it.

    #3879
    jwojwo
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    Thank you so much, that would be so very appreciated.

    Jeremy Warmsley / Summer Camp
    facebook.com/summercampmusic

    #3880
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    The latest nightly is built with 10.5 SDK, please try it and let me know if it works.

    #3881
    tribo
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hi all
    I’ve just tried the latest nightly and stable, and can’t get either of the standalones to work… I’m on osx 10.5.8
    Bug report follows:

    Process: Ctrlr-i386 [231]
    Path: /Applications/Ctrlr-i386.app/Contents/MacOS/Ctrlr-i386
    Identifier: com.instigator.Ctrlr
    Version: ??? (???)
    Code Type: X86 (Native)
    Parent Process: launchd [106]
    Interval Since Last Report: 303 sec
    Crashes Since Last Report: 2
    Per-App Interval Since Last Report: 0 sec
    Per-App Crashes Since Last Report: 7
    Date/Time: 2012-09-02 12:00:33.290 +0100
    OS Version: Mac OS X 10.5.8 (9L31a)
    Report Version: 6
    Anonymous UUID: 135606CF-B36A-428C-895E-176E7DC20660
    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0
    Dyld Error Message:
    unknown required load command 0x80000022
    Model: MacBookPro3,1, BootROM MBP31.0070.B07, 2 processors, Intel Core 2 Duo, 2.2 GHz, 2 GB
    Graphics: GeForce 8600M GT, GeForce 8600M GT, spdisplays_pcie_device, 128 MB
    Memory Module: global_name
    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), 1.4.16.2
    Bluetooth: Version 2.1.9f10, 2 service, 0 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    PCI Card: pci168c,24, sppci_othernetwork, PCI Slot 5
    Serial ATA Device: FUJITSU MHW2120BH, 111.79 GB
    Parallel ATA Device: MATSHITADVD-R UJ-857E
    USB Device: Built-in iSight, (null) mA
    USB Device: Apple Internal Keyboard / Trackpad, (null) mA
    USB Device: IR Receiver, (null) mA
    USB Device: Bluetooth USB Host Controller, (null) mA

    #10135
    djtempo7
    Participant
    • Topics: 0
    • Replies: 3
    • Total: 3

    I’m running 10.5.8. Can’t get anything to work. Standalone or VST.

    Help?

    Chip Tredo

    #10137
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    10.5 is an ancient operating system, the implications involved with supporting builds for 10.5 are huge as many many things have changed with the OS. I can’t speak for atom but considering the amount of work necessary to make builds that support 10.5< it probably wouldn't be worth the effort and would benefit only a very very small percentage while holding back development for the majority running more modern operating systems. I can understand not jumping on 10.8 or maybe 10.7 but if you're not able to go up to 10.6 because you're still on 10.5 there is a LOT more than ctrlr that you won't be able to run!

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #10138
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I think 10.5 was still PPC but 10.6 did not support it.

    All i can do is try to decrease the compatibility framework version to 10.5 if Xcode 4 allows it (i doubt that it will, apple is making harder and harder to keep stuff compatible).

Viewing 11 posts - 1 through 11 (of 11 total)
  • The forum ‘OSX’ is closed to new topics and replies.
There is currently 0 users and 60 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr