1159-61 bugs

Home Forums General News and releases 1159-61 bugs

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #761
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    resources – I like the new lay out – lots, but I can’t remove or add any resources.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4950
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    crap i forgot about that, i’ll fix it and re-build it asap. maybe i can add/fix something else while i’m at it.

    #4951
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    [b:2xa64lt7]Lua editor [/b:2xa64lt7]
    hrm.. Lua editor doesn’t open (from Panel>Lua Editor) on a panel that might possibly have some Lua errors.. the same panel that would crash ctrlr 1152/54 when I would try to open the panel…

    ahh but the Lua Editor does open if I click one of the pencil icons next to a script on the right in edit mode.

    My other panels the Lua editor opens though with no problem. But when I go to Panel>Lua Editor with the one panel I’m heavily devin’g at the moment I can see a standard windows XP window (I’m using win xp sp 3) start to draw but then vanish. no additional tabs open in my windows task bar, but a ctrlr icon starts to draw when the window draws, then vanishes.

    [b:2xa64lt7]Saving panels[/b:2xa64lt7]
    Again I love the layout and GUI refinement but I can’t seem to differentiate between the different file types when I go to save as. I only can save as a .panel file?

    [b:2xa64lt7]MIDI device settings[/b:2xa64lt7]
    I think most users are going to expect to be able to set their MIDI devices in the MIDI file menu, I don’t see this in any of the file menus… I think unfortunately most (new) users probably will take a while to find this under the actual panel settings in edit mode on the far right.. not a big deal but worth considering.[b:2xa64lt7] Maybe I’m just completely blind and am just not seeing it in the file menu.[/b:2xa64lt7] — oh in the panel properties but I just noticed it doesn’t actually stick when you set midi devices here from the panel preferences screen. If you set them there the same devices dont appear in the panel’s general tab.. possibly just a refresh issue (there’s no refresh button any more?)

    also, the comparator table doesn’t open anything at the moment, at least not here and the "Quick Toolbar" doesn’t open anything here either under View in the file menu.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4952
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    the comparator tables dump output to the log viewer,
    the quick toolbar is a work in progress

    saving panels is saving in the original format, every other format is in the Export menu.

    #4953
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I found a major bug in MidiMessage creation and also made the modulator list and the resource manager usable, i’ll post the build in an hour or so.

    also windows might appear and disappear quickly (like the lua editor) thats fixed

    #4954
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    I think anything I listed here seems fixed in 1161, if not "fixed" you at least addressed it above in your reply. One minor thing I see is that there used to be a "refresh" button that would appear on the general editor tab if you just imported resources. Now it’s back to the old way where you have to click some modulator and then back to the panel’s bg to get the general tab to refresh. not something i’ll loose sleep over just wanted you to be aware.

    ugh.. just got back from having work done on a root canal. I feel like chewing the inside of my mouth.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4955
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    Can’t find the layer window, it should be in the panel tab.

    EDIT: Solved, it was under View tab.

    #4956
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    I have a problem with rev. 1161. A panel I’m working on sends a dump request on start. The dump consist of 63 blocks of 69 bytes each one. When the panel receives the dump, the midiMessageReceived method stop working (midi messages are received by the panel as seen on the midi monitor, but the method don’t work any more. Even if change the method’s code to a simple "hello" message when a message is received it doesn’t work. If I disable the dump request on start, the method works fine.

    The same panel works fine on rev. 1102

    #4957
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    so I guess some of the bugs I reported for 1159 are fixed in 1161 but there is still is some strange stuff going on.

    I worked a bit with my panel on sunday/monday after grabbing 1161. Things were working ok, I isolated some problem areas in some of my scripts and commented them out.

    Been a bit busy this week w/ other stuff, then I came back to the panel and it’s back to crashing when opening. I can disable Lua in the prefs and open the panel that way but I haven’t been able to identify where the issues are coming from.
    The panel opens ok in 1102 and is giving no errors.

    Frustrating thing is that the log file doesn’t show anything questionable when 1161 crashes. I know from chatting w/ him that dasfaker has been having similar issues. So… I’ve basically had to walk away from this for a bit as I haven’t had the time/wherewithal to go through line for line and find bugs w/o the help of any sort of debug or error reporting.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

Viewing 9 posts - 1 through 9 (of 9 total)
  • The forum ‘News and releases’ is closed to new topics and replies.
There is currently 0 users and 99 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr