Can't open panel

Home Forums Platform Specific Linux Can't open panel

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #27683
    keefaz
    Participant
    • Topics: 4
    • Replies: 4
    • Total: 8

    Hi,

    Have tried with both the precompiled standalone Ctrlr-x86_64 5.2.111 and another compiled from source. Both start fine, but don’t display the open dialog when I select File > Open Panel menu.

    The logs are filed with:

    JUCE Assertion failure in juce_LeakedObjectDetector.h:95
    JUCE Assertion failure in juce_LeakedObjectDetector.h:95
    JUCE Assertion failure in juce_LeakedObjectDetector.h:95
    ….

    Os: Slackware Linux 14.1
    Arch: x86_64

    I can give more information about libraries versions etc..

    Thanks

    #27689
    atomatom
    Participant
    • Topics: 157
    • Replies: 2943
    • Total: 3100
    • ★★★★★

    What graphic environment are you using ? GNOME/KDE ? This looks like an issue with the native open file dialog, i’d have to install Slackware (i’m ashamed to admit i wasn’t using it lately) to see what’s up.

    #27695
    keefaz
    Participant
    • Topics: 4
    • Replies: 4
    • Total: 8

    I use xfce 4.10 which is similar to GNOME (use mainly GTK2 and GTK3 libraries)

    Thanks

    #27696
    keefaz
    Participant
    • Topics: 4
    • Replies: 4
    • Total: 8

    Ok, just started a KDE session and run Ctrlr, in this Desktop Environment the open dialog works.

    I tried other Desktop environments: TWM and Fluxbox, open dialog doesn’t work.

    So far it seems it works only on KDE, I don’t know why, other QT applications work fine in xfce…

    Thanks

    [edit]
    After a file search, I found
    ctrlr-master/Juce/modules/juce_gui_basics/native/juce_linux_FileChooser.cpp

    It seems only KDE (kdialog) and GNOME (zenity) are supported, no?

    [edit 2]
    I finally made it able to open dialog in xfce, just fool the juce filechooser pretending it is in running KDE session by starting Ctrlr as:

    
    KDE_FULL_SESSION=true ./Ctrlr-x86_64
    • This reply was modified 5 years, 5 months ago by keefaz.
    • This reply was modified 5 years, 5 months ago by keefaz.
    • This reply was modified 5 years, 5 months ago by keefaz.
    #64422
    amagnolo
    Participant
    • Topics: 1
    • Replies: 6
    • Total: 7

    I have the same problem on Lubuntu 15.10 (LXDE/Openbox): Ctrlr freezes on panel open/save.
    Is there any workaround?

    #64634
    amagnolo
    Participant
    • Topics: 1
    • Replies: 6
    • Total: 7

    update: if I do
    export KDE_FULL_SESSION=true
    before the first launch of Ctrlr it works. Otherwise, after Ctrlr is launched without that variable set, subsequent launches won’t work, until the pc is rebooted.

    #67403
    amagnolo
    Participant
    • Topics: 1
    • Replies: 6
    • Total: 7

    I still have occasional program freezes on file dialog open (also when trying to add a resource). I tried to set “Use OS native dialog windows” in preferences but nothing changes.
    The only workaround is to reboot the computer until you get lucky and the dialog box finally opens…

    These might be useful for diagnosing:
    http://www.juce.com/forum/topic/freeze-when-opening-filechooser
    http://www.juce.com/forum/topic/fixes-native-zenity-linux-file-dialog-patch

    • This reply was modified 4 years ago by amagnolo.
    #67442
    atomatom
    Participant
    • Topics: 157
    • Replies: 2943
    • Total: 3100
    • ★★★★★

    I get the same thing, it’s the Linux’s zenity or whatever that is responsible for the dialog to pop-up, it freezes so Ctrlr freezes waiting for zenity to show. Anyway i’ll see if i can implement a JUCE-only open dialog for Linux so that we can bypass this zenity mechanism.

    #67457
    atomatom
    Participant
    • Topics: 157
    • Replies: 2943
    • Total: 3100
    • ★★★★★

    Well if you are building from sources, you can pull the latest source from github and re-build, a global option has been added to toggle native OS/native JUCE open/save dialogs, that should help.

    #67618
    amagnolo
    Participant
    • Topics: 1
    • Replies: 6
    • Total: 7

    I tried the 5.3.178 binary with the new option and it works all right; I noticed that the “add resource” dialog still uses zenity but it works even without the KDE_FULL_SESSION variable. Even the “open panel” dialog now works with zenity.
    Anyway, I haven’t experienced any freeze with this build, so the problem seems solved, thank you very much!

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
There is currently 0 users and 18 guests online
No users are currently active
Forum Statistics
Threads: 2,275, Posts: 15,922, Members: 57,248
Most users ever online was 12 on January 22, 2019 3:47 pm
Do NOT follow this link or you will be banned from the site!