changing/ removing vst index

Home Forums General Using Ctrlr changing/ removing vst index

Viewing 20 posts - 1 through 20 (of 26 total)
  • Author
    Posts
  • #11555
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    I have a few modulators which I want to remove the vst index as they are set to not be used in the vst panel but after saving and reopening the panel their vst index returns. I’ve tried both setting to zero and removing/deleting the index number but they always return.

    Then I have modulators for which I set the vst index to a specific desired value but upon saving and reopening the panel the vst index numbers seem random.

    This is intermittent and seems random as some modulators vst index “sticks” without issue.. any ideas?

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #11556
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    You can’t have duplicates, if the program detects any it re-indexes modulators so they’re kept unique.

    My advice is to set the indexes (you want to change) to something very high, open the modulator list, sort stuff based on the index and then change them so there are no duplicates.

    Also to remove the modulator from the list of vst indexes, use the special property modulatorVstExported, set it to false (it won’t be on the list).

    Also i think (looking at the code now), you might need to re-start Ctrlr (re-open the panel) to make Ctrlr re-read those indexes.

    #11873
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    cool. I didn’t spend any more time with attempting to resolve this on my end as I had already gone through similar steps as what you suggested above – I sorted my modulator list window by VSTindex, identified/resolved any duplicates, saved panel, closed panel, closed ctrlr, reopened all and my changes previously saved to remove any duplicates and make all index numbers unique seemed ignored – a little time consuming to keep ending up with the same result so I moved on to other things.

    You mentioned, atom in another thread (i believe the “change modulator type” thread) that you were working on this index issue so I’m assuming there’s some fix for this coming at some point unless you have further suggestions on how I can resolve this on my own?

    Cheers, thanks as always!

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #11875
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Yeah the old VST index handling is unpredictable at best. The next nightly when it comes will fix that, you’ll be able to manage that easily, i’m testing this and once i consider it stable i’ll do the nightly build.

    The warning messages stuff is already there and works, you can just create an empty Lua method that does nothing and it should go away.

    #11876
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    awesome. hopefully my other post in the other thread makes sense.. I’m trying to tie up as many loose ends on my current panels before releasing my next one for the original microwave.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #12321
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    Hi Atom

    Is there a way to fix vst indexes definitively ? in “called before any mod is created” ? just by setting “vst index”and “vstExportedMax”
    in advance?……
    On the RApanel i would upload , indexes are completely disordered
    The problem : 2200 mods (1970 vstexported)
    Since i remove or add even few mods that’s quagmire . i’ve done some snapshots , may be this disorder vst indexes too…
    a question : what is the order of “snapshot” in the PM ? vst index ?

    #12323
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    You can try to do that with the new nightly. Use the modulator list, the vst manager is now new, i’m not saying that it’s better and will solve your problems. It should, but i didn’t tetst it enough to say for sure.

    #12340
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    Hi
    I tried the last nightly and the modulator list is not working for me
    i can’t filter and order by syx ,name or other , i can’t change values of the vst index in tree or list mode

    #12357
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Hi
    I tried the last nightly and the modulator list is not working for me
    i can’t filter and order by syx ,name or other , i can’t change values of the vst index in tree or list mode

    Which OS? I’m using os x 10.6.8 and this is the first thing I looked at – reseting these darn VST index values to their appropriate value. While I CAN sort by sysex formula, name, other with no issue I am NOT able to edit the VST index, either from the modulator list or the modulator’s property pane on the right side. I select the current value “359”, hit delete, deselect the field but “359” returns immediately. Even if i try to change the value from 359 to 8 or something, the moment I deselect the value it reverts to 359.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #12365
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    Same thing than you + i can’t sort

    I’m on w7 x64 this issue is in rev1522 too

    I’ve an issue with the checksum too :

    1522 : ctrlr can send message to unit with no errors but not receive
    1535 : ctrlr can receive from unit with no errors but not send

    Plus it seems i’m the only one :

    my midi monitor disappears immediately when i open it in standalone i’ve already reported this but now it’s on second pc !!
    I believe this is midi device that causes this when it rejects invalid checksums but really not sure , that was happened at same time .

    I have a Ctrlr “blues” ….

    #12369
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    With a newer panel of another device the modulator list starts with only one property
    That’s cool !
    I can sort by any prop but the vst index issue is still here

    I Wonder if the property list settings could be saved with the panel , i could use it more

    modulatorVstExported default value to 0 when a new mod is created could help to organize vst indexes later ??

    #12376
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    Some feedbacks :

    On a recent panel i’m able to change vst index but as you see on the image i can’t set value 0 ( 0 is for every new mod ???)
    The problem is i can’t sort properties on the RA panel so i can’t nothing
    Another problem : on the recent panel i’ve set false all mods the property modulatorVstExported before setting vstIndex but with RA i must do that with 1970 mods

    Attachments:
    You must be logged in to view attached files.
    #12378
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    :I

    • This reply was modified 8 years, 9 months ago by zeoka.
    #12484
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I’m back from Paris, i’ll be doing the reported fixes asap.

    #12495
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    “Bonjour Mademoiselle , je vous trouve très jolie ! ” 🙂

    Good new Atom !

    Thank you

    #12496
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Paris blows hard. NIN concert was cool but the town of Paris is a crap experience. I’m already looking and the VST index issues.

    #12523
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    hahah paris. Never been. Had an opportunity while on tour once but broke my hand before getting out of Stuttgart. maybe I didn’t miss a thing after all! I sure would have liked to make it to Prague and Moscow tho.. 🙁

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #12538
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    The new build should have this working, i rebuilt the vst manager from scratch. You can have multiple modulators with the same VST index now, but only one will reacto to changes (the first one found in memory, this is non-deterministic, don’t count on it), it’s up to you to make your VST indexes unique.

    I checked the modulator list and with the normal numerical sorting it should all work fine.

    #12609
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    Atom ,
    Tried it !

    Working nice with the microQ panel the 0 vstindex is asignable now

    But there is nothing to do with the RA panel :
    I can sort and assign only vstindex , that’s the essential but i still can’t sort by sysex or anything else
    Strange thing : vst index starts to 270 aprox.
    To have aprox. the same list (vst,vst export, name,sysex )i reset to default
    Could i send to you the panel then if you have some time , you could see where is the problem ?

    Attachments:
    You must be logged in to view attached files.
    #12612
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Both the numeric and the lexicographical comparison types have the same result ?

    And yes send the panel i’ll see what’s up.

Viewing 20 posts - 1 through 20 (of 26 total)
  • The forum ‘Using Ctrlr’ is closed to new topics and replies.
There is currently 0 users and 46 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr