Combobox’s need reset after saved in a panel…

Home Forums General Using Ctrlr Combobox’s need reset after saved in a panel…

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #755
    Synthetech
    Participant
    • Topics: 13
    • Replies: 70
    • Total: 83

    I too am having some issues with ComboBoxes.

    I’ll have a panel open and get a combobox to work properly.
    The moment I save it and then reopen it, I have to go back into a combobox and "reset" the Midi Message Type.. if it’s a Multi message, I have to click on CC and then back to Multi again.. then it will start working.

    I have to do this every time I save the project.

    If it helps, this panel originally started it’s build in v1102 . Then I updated it to 1137 and ever since then I cant seem to get these combo boxes to behave correctly after I’ve saved/closed/ reopened… even when I reset the Midi Message Type, then save.. it happens again.

    If I make a new combobox in 1137, get it working, save the panel, re-open.. that new combobox will work.
    I just hate to have to go back in and recreate 30+comboboxes..

    I also noticed that it wont remember that I have Midi In/Out set for use with my Roland UM-ONE usb interface.. everytime I close/reopen the panel, I have to go back in and tell it to use the USB interface.

    I’m hoping there’s an easy fix.

    -Blaine

    #4939
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★
    "Synthetech":1gxkh9u7 wrote:
    I too am having some issues with ComboBoxes.

    If it helps, this panel originally started it’s build in v1102 . Then I updated it to 1137 and ever since then I cant seem to get these combo boxes to behave correctly after I’ve saved/closed/ reopened… [/quote:1gxkh9u7]

    Interesting info.. unfortunately I haven’t been able to reproduce exactly what you’re saying.. I opened 1102, created two comboboxes. One is set to send sysex message, the other is set to send CC22. I save the panel, close ctrlr, then open the same panel in 1137 (either after clearing ctrlr cache w/ ctrl+R or not clearing cache) and when I open the midi monitor the two combo boxes both send either sysex or cc whichever they’re set to send… So on one hand it was encouraging to know someone else was having combobox issues yet I wasn’t able to reproduce what you describe here, win 7 x64. <img loading=” title=”Neutral” />

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4940
    Synthetech
    Participant
    • Topics: 13
    • Replies: 70
    • Total: 83

    I’ll post the panel in here so you can perhaps see for yourself?

    [attachment=0:eg69j9xu]PolyGone Keyboard V6-33.bpanelz[/attachment:eg69j9xu]

    The white combobox should work/send a CC

    chances are, the rest of the comboboxes wont send anything until you go in and reset the midi type and sometimes even the message parameters too..

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Using Ctrlr’ is closed to new topics and replies.
There is currently 0 users and 30 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr