crashes osx 10.5.8

Home Forums Platform Specific OSX crashes osx 10.5.8

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #748
    riffkillsman
    Participant
    • Topics: 1
    • Replies: 1
    • Total: 2

    hi new to the board here. Im having trouble getting ctrlr to open on my desk top. i dragged ctrlr to my applications , and dragged and dropped the au, and vst into the library component and vst folders. i have tried this every day for the last week downloading another version each day, the standalone app crashes on open every time. i got ctrlr to open in both numerology and audiomulch, however it will freeze up after i put ctrlr into full screen? i want to only use the stand alone app for editing my waldorf. please let me know if im missing a step somewhere? i tried repairing my system disk permissions and that didnt help at all.
    anything else i could try?

    #4913
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    The crashes might be (i’m pretty sure that’s the cause) because i build Ctrlr with SDK version 10.6 and i know of many issues that exist if you build with 10.6 SDK and try to run stuff on 10.5 systems. I can again try to build Ctrlr with 10.5 SDK but it might not work (since JUCE moved forward), i will remember about that the next time i do a nightly build but i promise nothing. I only have a VM with OSX 10.7, i don’t own a MAC i shouldn’t be doing the MAC builds at all really.

    #4914
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Atom-
    VMware should be sufficient for building app progs for os 10.6.. I’m running 10.6.7 and 10.6.8 and I know I can get ctrlr standalone open and working with many of my own panels.

    Riff, can you paste the os x log from console? The logs should give some clue.. Applications/Utilities/Console
    Click "show log list", then click "all messages", then click "clear display". Now try and launch ctrlr, then copy paste the log output from Console in a reply here.

    I’m assuming you repaired disk perms before and after "installing" ctrlr? That was my first hunch.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4915
    riffkillsman
    Participant
    • Topics: 1
    • Replies: 1
    • Total: 2

    hi guys thanks for your help. I also have an imac that runs 10.6.8 so i installed ctrlr there and it works just fine!

Viewing 4 posts - 1 through 4 (of 4 total)
  • The forum ‘OSX’ is closed to new topics and replies.
There is currently 0 users and 28 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr