linux VST

Home Forums Platform Specific Linux linux VST

Tagged: 

Viewing 20 posts - 1 through 20 (of 41 total)
  • Author
    Posts
  • #26252
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    I’m having trouble getting the linux VST to open in bitwig 64 bit in ubuntu 14.04 64 bit.

    I’ve tried the last several linux builds, placed the .so into usr/lib/lxvst chmod 777’d the .so files, no dice. before i continue chasing down the rabbit hole – the .so works as a linux VST, correct?

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #26256
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    The latest binary was indeed not working, don’t know why will have to check it out. I just updated the linux build to a new one, please try it.

    #27042
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Checking this out now.. thanks atom – been in the desert on a get away vacation for a while – just getting back 🙂

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #27043
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    nope, no love. At least not in bitwig – I reported this issue to their forum a while back when running the previous version 1.0.10 (just upated to 1.0.11)

    From the report in terminal it seemed like an issue where bitwig was trying to run the 64 bit plugin within a 32 bit pluginhost. According to bitwig – it is but only after the plugin fails within the 64 bit plugin host.

    Previously it was failing in the 64bit host w/ an “undefined symbol error”

    http://answers.bitwig.com/questions/873/on-linux-loading-64-bit-so-plugins?page=1#957

    Attachments:
    You must be logged in to view attached files.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #27049
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I’ll check this out, i never knew a program like that existed.

    #27050
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Scratch that i will not test this, bitwig is expensive as hell 🙂 i’ll try some other linux based hosts.

    #27117
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Ok. I tried ardour, renoise and lms, no love.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #27119
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I tried the Juce Plugin Host and it worked, i’ll try some others i can find tomorrow at work.

    #27141
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Is the Juce plugin host loading the linux plugin as a linuxVST, DSSI, LV2? Which is the Ctrlr VST.so supposed to loaded as? incidentally on the same ubuntu 14.04 x64 linux partition I’m not able to launch the stand-alone from the 5.2.75 package. I’m getting “error while loading shared libraries: libbfd-2.22-system.so: can not open shared object file: No such file or directory”

    This is a relatively fresh 14.04 install with nothing else but bitwig, Jack, JackRack, LV2 rack, Ardour and LMMS installed… I’ll give ubuntu studio 14.04 x64 a spin . . .

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #27147
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Well if you are missing some .SO libraries you need them, in this case it’s the binutils-dev package i think.

    #27148
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    it’s a VST plugin, not LADSPA not DSSI only VST.

    #27165
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Well if you are missing some .SO libraries you need them, in this case it’s the binutils-dev package i think.

    Thats what I thought also – both binutils and binutils-dev are installed … Still getting error while loading shared libraries: libbfd-2.22-system.so: cannot open shared object file: No such file or directory
    on both the regular ubuntu 14.04 and ubuntu studio 14.04 partition.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #27166
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    You might have the .so file but with a different version, do

    # find /usr -name “libbfd*.so”

    and see what files you have.

    #27168
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    I’m getting this same thing on regular ubuntu 14.04, screenshot is from ubuntu studio.
    Synaptic seems to infer I have libbfd 2.24
    A find with the syntax you supplied seems to not be able to find libbfd installed, (although not pictured, even w/o the /usr location specification.)

    As you can see I have binutils-dev and binutils-multiarch-dev installed.

    Attachments:
    You must be logged in to view attached files.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #27170
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    You can try fooling the OS and symlink your existing library:
    https://groups.google.com/forum/#!topic/grive-devel/KVU3G8BhDWg

    #31050
    pierrotlo
    Participant
    • Topics: 0
    • Replies: 9
    • Total: 9

    Hi,
    .
    I have the same problem with Kxstudio, based on ubuntu 14.04.

    ./Ctrlr-x86_64: error while loading shared libraries: libbfd-2.22-system.so: cannot open shared object file: No such file or directory
    

    The /usr/lib/libbfd-2.24-system.so is installed and the symlink is OK :

    locate libbfd-2.22-system.so
    /usr/lib/libbfd-2.22-system.so
    • This reply was modified 7 years, 8 months ago by pierrotlo.
    • This reply was modified 7 years, 8 months ago by pierrotlo.
    #31054
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Can you paste the output of the command
    # file /usr/lib/libbfd-2.24-system.so
    and
    # file Ctrlr-x86_64

    ?

    #31066
    pierrotlo
    Participant
    • Topics: 0
    • Replies: 9
    • Total: 9
    $ file /usr/lib/libbfd-2.24-system.so
    /usr/lib/libbfd-2.24-system.so: ELF 64-bit LSB  shared object, x86-64, version 1 (SYSV), dynamically linked, BuildID[sha1]=ba0d3f30012734d9c30b1f7df1b7694a299da337, stripped
    
    $ file Ctrlr-x86_64 
    Ctrlr-x86_64: ELF 64-bit LSB  executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=811dd2a9ddfac5ba513031820ea85b9a4066a34e, stripped
    #31069
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Then i don’t know what’s wrong.

    You can try
    # ldd Ctrlr-x86_64 to see the full path of all libraries linked to Ctrlr

    run
    # ldconfig

    to update the linker cache

    if they’re there and you get the error message then the linker is not seeing the libraries in those directories. Either you have a custom LD_LIBRARY_PATH or some weird settings in /etc/ld.so.conf*

    otherwise i have no idea what could be wrong

    #31073
    pierrotlo
    Participant
    • Topics: 0
    • Replies: 9
    • Total: 9

    Hi,
    LD_LIBRARY_PATH is empty
    I have three folders
    /usr/lib wich contain the libbfd-2.24-system.so and the symlink libbfd-2.22-system.so
    /usr/lib64
    /usr/lib32

    OK I did make this :

    chmod 777 libbfd-2.24-system.so
    rm -f the symlink libbfd-2.22-system.so
    sudo ln -s /usr/lib/libbfd-2.24-system.so /usr/lib/libbfd-2.22-system.so

    If I run Ctrlr in a terminal, now the result is :

    Instruction not permitted
    
    • This reply was modified 7 years, 8 months ago by pierrotlo.
Viewing 20 posts - 1 through 20 (of 41 total)
  • The forum ‘Linux’ is closed to new topics and replies.
There is currently 0 users and 53 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr