MIDI input from host no longer working (VST mode)

Home Forums General Using Ctrlr MIDI input from host no longer working (VST mode)

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #585
    schpinn
    Participant
    • Topics: 1
    • Replies: 5
    • Total: 6

    In the previous nightly I could enable MIDI input from host and see all the modulators responding to any automation I have recorded inside my DAW (Ableton Live). And I didn’t need to enable any MIDI input inside Ctrlr because Ableton passed all the MIDI data to my panels. I cannot get this to work in the latest nightly. Is there something I’m missing, or is this a bug?

    #4148
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    You need to be more specific, there are 3 ways you can change a modulator in a Ctrlr panel
    – by automating it from the host as a VST/AU parameter (no midi involved)
    – by sending it MIDI from the host
    – by sending it MIDI from the MIDI Device opened in Ctrlr

    witch one is not working 4u. I also must admit that the last nightly was waaaay to early and i need to fix a lot, so be patient i’m working on it (i just don’t have so much time now it’s my first day at my new job tomorrow so i’m stressed to the max)

    #4149
    schpinn
    Participant
    • Topics: 1
    • Replies: 5
    • Total: 6
    "atom":1vaxrqbt wrote:
    You need to be more specific, there are 3 ways you can change a modulator in a Ctrlr panel
    – by automating it from the host as a VST/AU parameter (no midi involved)
    – by sending it MIDI from the host
    – by sending it MIDI from the MIDI Device opened in Ctrlr

    witch one is not working 4u.[/quote:1vaxrqbt]

    I apologize for being so vague. I was talking about sending MIDI from the host, Ctrlr is not responding to any MIDI (CC) data sent from the host. It is passing it through to my device, but none of the modulators seem to be moving.

    I also just checked automating VST parameters, and it seems that my host cannot see any of the modulators in Ctrlr anymore. The strange thing is that if I open an old project with some VST parameters already added and automated, those still work, but I can’t seem to add any new ones.

    Sending MIDI from the device opened in Ctrlr works normally.

    "atom":1vaxrqbt wrote:
    I also must admit that the last nightly was waaaay to early and i need to fix a lot, so be patient i’m working on it (i just don’t have so much time now it’s my first day at my new job tomorrow so i’m stressed to the max)[/quote:1vaxrqbt]

    No problem, this is still an incredibly useful piece of software, despite it having a bug here or there <img loading=” title=”Smile” />. And good luck at your new job!

    #4150
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Exit edit mode in your panel, right click on it and go to panel properties, check "Accept midi from host" and "MIDI input goes to comparator"

    #4151
    schpinn
    Participant
    • Topics: 1
    • Replies: 5
    • Total: 6
    "atom":34nlaj4w wrote:
    Exit edit mode in your panel, right click on it and go to panel properties, check "Accept midi from host" and "MIDI input goes to comparator"[/quote:34nlaj4w]

    I already did turn on these options, but they don’t seem to be having any effect. Just to be sure it isn’t a problem with my panels, I tried creating a new one with just one parameter (CC105 I think), and it didn’t work there as well. Sending MIDI CC105 from Ableton didn’t seem to do anything. I tried all combinations of all options and settings, tried rebooting my PC, restarting Ableton, restarting my audio device, but nothing seems to help.

    As for the VST parameters, I don’t know if this is a problem with Ableton or with Ctrlr, but I did some more testing and it turns out Ableton can see only some Ctrlr’s modulators (eg. in the A Station panel from the DDB it cannot see the filter frequency, but can see all the parameters for OSC1).

    #4152
    LilCthulhu
    Participant
    • Topics: 9
    • Replies: 67
    • Total: 76

    [quote:1dw3egpi]
    atom wrote:
    I also must admit that the last nightly was waaaay to early and i need to fix a lot, so be patient i’m working on it (i just don’t have so much time now it’s my first day at my new job tomorrow so i’m stressed to the max)[/quote:1dw3egpi]
    [quote:1dw3egpi]
    No problem, this is still an incredibly useful piece of software, despite it having a bug here or there . And good luck at your new job!
    [/quote:1dw3egpi]

    I couln’t agree more ! Fantastic piece of MIDI/IDE/SDK you did here <img loading=” title=”Wink” /> I’m current still using an old nightly … Where can we download previous nightly ? (more stable-one but yet above release ?)

    #4153
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I replace the binaries when i do a release so i’m afraid i don’t have that but i’m sure someone has the previous nightly build and can share it. I’m fixing the bugs and re-working some stuff right now. I can’t tell you when will it be ready i’m afraid there is a lot to do, i made one change that caused a domino effect and now i have to fix a lot of stuff.

    #4154
    TK.
    Participant
    • Topics: 6
    • Replies: 42
    • Total: 48

    Here’s a copy of the r946 build for MacOS:
    http://www.ucapps.de/tmp/Ctrlr_r946.dmg

    Best Regards, Thorsten.

    #4155
    schpinn
    Participant
    • Topics: 1
    • Replies: 5
    • Total: 6
    "schpinn":1phyguxh wrote:
    "atom":1phyguxh wrote:
    Exit edit mode in your panel, right click on it and go to panel properties, check "Accept midi from host" and "MIDI input goes to comparator"[/quote:1phyguxh]

    I already did turn on these options, but they don’t seem to be having any effect. Just to be sure it isn’t a problem with my panels, I tried creating a new one with just one parameter (CC105 I think), and it didn’t work there as well. Sending MIDI CC105 from Ableton didn’t seem to do anything. I tried all combinations of all options and settings, tried rebooting my PC, restarting Ableton, restarting my audio device, but nothing seems to help.

    As for the VST parameters, I don’t know if this is a problem with Ableton or with Ctrlr, but I did some more testing and it turns out Ableton can see only some Ctrlr’s modulators (eg. in the A Station panel from the DDB it cannot see the filter frequency, but can see all the parameters for OSC1).[/quote:1phyguxh]

    I am still unable to get these two things to work. If there’s anything I can do to help you diagnose and fix the problem, please let me know.

    #4156
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Are you using the latest nightly build?

    Anyway please send me a Ableton project with Ctrlr inserted and set up to receive midi from host (the simple panel you did might also be of help, though it will be saved with the project). And i will debug it, i really don’t know how to route midi to plugins in ableton so that will help.

    #4157
    schpinn
    Participant
    • Topics: 1
    • Replies: 5
    • Total: 6
    "atom":2i3jwbhj wrote:
    Are you using the latest nightly build?

    Anyway please send me a Ableton project with Ctrlr inserted and set up to receive midi from host (the simple panel you did might also be of help, though it will be saved with the project). And i will debug it, i really don’t know how to route midi to plugins in ableton so that will help.[/quote:2i3jwbhj]

    Yes, this is using the latest nightly.

    I have made a small project with 3 MIDI clips, the first one is automating via MIDI CC105, with just a straight line from the lowest to the highest value, and again back to the lowest. The second MIDI clip was recorded via one of my synths, sending CC105 as well, but here I’ve randomly moved the knob around. The third clip is automating via the VST parameter.

    https://www.dropbox.com/s/ow7yjtwqg5te1y7/CtrlrTest.zip

    The good news is that I’ve managed to get it working. The bad thing is, it seems that it’s sometimes working, and sometimes not. And sometimes when it’s working, the modulator is not moving smoothly. But then, if you change some settings in the panel properties, it starts moving smoothly again. And it’s always smooth when it’s automated via the VST parameter.

    Also, when it’s automated via the VST parameter, Ctrlr sends the associated MIDI CC105 value (which is the filter cutoff in my case) and my synth receives it and responds to it. But shouldn’t Ctrlr also be sending MIDI out when the modulator is automated via MIDI CC (as in the first two clips)? It does send it when "Thru from host to device" and "channelize" are activated, though. Is this the expected behavior?

    It also seems that Ableton can now see all VST parameters, I just had to close all my panels in my Ctrlr instances and re-open them, so sorry about that.

    EDIT: typo gallore.

    #4158
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Well if Ctrlr receives a MIDI message that changes a modulator it won’t re-send the same MIDI message out, that would cause a feedback loop.

    #4159
    schpinn
    Participant
    • Topics: 1
    • Replies: 5
    • Total: 6
    "atom":2qmd64xe wrote:
    Well if Ctrlr receives a MIDI message that changes a modulator it won’t re-send the same MIDI message out, that would cause a feedback loop.[/quote:2qmd64xe]

    Honest question, what’s the point of automating modulators via MIDI messages then?

    #4160
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I don’t think we understand each other. You build a panel that has some controls, each control has a MIDI message assigned to it, let’s say a CC message, you hook up your panel to a MIDI in and out, the panel transmits the right CCs to the synth. When you twist the knobs on the synth it generates the same CCs that hit Ctrlr and the right component (with that CC assigned on the panel) changes it’s state depending on the value sent from the synth, in that moment it would be stupid to re-send the same message to the Synth, since it JUST sent it to us (unless some sort of midi THRU option is set).

Viewing 14 posts - 1 through 14 (of 14 total)
  • The forum ‘Using Ctrlr’ is closed to new topics and replies.
There is currently 0 users and 55 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr