setModulatorValue is sending to MIDI-Out

Home Forums General Using Ctrlr setModulatorValue is sending to MIDI-Out

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #50519
    PossemoPossemo
    Participant
    • Topics: 14
    • Replies: 604
    • Total: 618
    • ★★★

    Hi, it would be nice if someone could help me.

    My problem: Some Modulators are sending the values they receive via setModulatorValue, setValue or setValueMapped to MIDI-Out. They are identical to the ones that do not send unwanted data to MIDI-Out. One thing that I can say: they are all UiCombos. But as said, there are some UiCombos that are behaving correct.

    I tried many things to get rid of this, but nothing helped.

    So can someone tell me what’s wrong with this line?

    panel:getModulatorByName("UpperKeyAssign"):setModulatorValue
    (patchDump:getByte(38),true,false,true)

    Or here another one:

    pmod=panel:getModulatorByName("BendRng")
    Lo=patchDump:getByte(30)
    Hi=patchDump:getByte(59)
        if Lo==0x00 and Hi==0x00 then pv=0
    elseif Lo==0x20 and Hi==0x00 then pv=32
    elseif Lo==0x40 and Hi==0x00 then pv=64
    elseif Lo==0x60 and Hi==0x00 then pv=96
    elseif              Hi==0x01 then pv=127
    end
    pmod:setValueMapped(pv,false,true)
    • This topic was modified 5 years ago by PossemoPossemo.
    #50523
    dasfaker
    Keymaster
    • Topics: 79
    • Replies: 786
    • Total: 865
    • ★★★

    Yes, this is a known bug, combos ignore the “false” setting.

    The ones you see are behaving correctly, it’s very possible that the value they receive is the same value they had previously, that’s why they don’t send any new value.

    What I do is to use panel property “No MIDI output from panel” when I assign values to modulators after receiving a dump.

    #50552
    PossemoPossemo
    Participant
    • Topics: 14
    • Replies: 604
    • Total: 618
    • ★★★

    Thanks dasfaker,

    I just wantet to add that every uiCombo has the bug, as you say – the ones that do not send data receive the same value as they already have (first switch: false). “No MIDI output from panel” is a workaround for this – thanks. I am thinking about changing a few uiCombos to uiListBox. I like the ListBox as it shows you all possible settings of a prameter at once. But yea of course I needs more space on the screen.

    #58111
    bloodykotbloodykot
    Participant
    • Topics: 0
    • Replies: 7
    • Total: 7

    I tried to set panel property “No MIDI output from panel” before changing modulator’s value but some uiCombos still send midi out messages due delay processing I suppose. I think there is two solutions of that issue. The fist one is using appropriate timer before restoring panel property. The second is setting uiCombo property “modulatorMute” before changing values and restoring after. Any idea?

    #58173
    PossemoPossemo
    Participant
    • Topics: 14
    • Replies: 604
    • Total: 618
    • ★★★

    I was not into Ctrlr for some time. I changed the uiCombos to uiListbox’es but I am still interested in a solution for uiCombos. May I ask – how do you set the switch “No MIDI output from panel” with LUA?

    #58174
    bloodykotbloodykot
    Participant
    • Topics: 0
    • Replies: 7
    • Total: 7

    Somehow like that:
    panel:setPropertyString(“panelMidiPauseOut”,”1″)
    I tried used to panel:setPropertyInt(“panelMidiPauseOut”,1) but it didn’t work for me.
    There is another way. It’s possible to midi mute uiCombor for a while.

    #58186
    PossemoPossemo
    Participant
    • Topics: 14
    • Replies: 604
    • Total: 618
    • ★★★

    Ah I see. There was a trhead about this:
    http://ctrlr.org/forums/topic/disable_midi_device_lua/

    Got to see how dasfaker did it. His Virus panels look like serious sh*t. A pity I do not have a Virus.

    Thanks bloodykot. Will keep you informed if I find out something new.

    Edit:
    So far that’s all I found in dasfakers Viruspanel:
    panel:setPropertyString(“panelMidiInputFromHost”,”1″)
    panel:setPropertyString(“panelMidiOutputToHost”,”1″)
    panel:setPropertyString(“panelMidiThruH2DChannelize”,”1″)
    panel:setPropertyString(“panelMidiThruD2HChannelize”,”1″)
    panel:setPropertyString(“panelMidiThruH2D”,”1″)
    It does not seem he used:
    panel:setPropertyInt(“panelMidiPauseOut”,1)
    Will look some further.

    • This reply was modified 4 years, 9 months ago by PossemoPossemo.
    #58444
    bloodykotbloodykot
    Participant
    • Topics: 0
    • Replies: 7
    • Total: 7

    I’m testing now solution like that:
    panel:getModulatorByName(“osc1wave”):setPropertyString(“componentDisabled”,”1″)
    panel:getModulatorByName(“osc1wave”):setModulatorValue(programData:getByte(31), true, false, true)
    panel:getModulatorByName(“osc1wave”):setPropertyString(“componentDisabled”,”0″)

    #58454
    PossemoPossemo
    Participant
    • Topics: 14
    • Replies: 604
    • Total: 618
    • ★★★

    Great, looks like a valid path. And as it just concerns uiCombos it’s not too much work. Unfortunately I don’t have much time at the moment but I definitely want to test this asap.

    #67969
    PossemoPossemo
    Participant
    • Topics: 14
    • Replies: 604
    • Total: 618
    • ★★★

    Hi bloodykot,
    Life has been hard – I had so much other things to do. But now I finally managed to test this out.
    With the newest Ctrlr-Build (5.3.183) this issue got even more important. Maybe it is me that broke something in my panel, don’t know. Anyway – the “false” parameter on the “setModulatorValue” command does not seem to work anymore.

    But hey, this works like a charm:
    panel:setPropertyString(“panelMidiPauseOut”,”1″)
    after Sysex-Messages reenable:
    panel:setPropertyString(“panelMidiPauseOut”,”0″)

    That’s it. Thanks bloodykot

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.
There is currently 0 users and 30 guests online
No users are currently active
Forum Statistics
Threads: 2,394, Posts: 16,752, Members: 59,355
Most users ever online was 12 on January 22, 2019 3:47 pm
Do NOT follow this link or you will be banned from the site!