setting an image for a modulator

Home Forums General Using Ctrlr setting an image for a modulator

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #69589
    mplmpl
    Participant
    • Topics: 1
    • Replies: 7
    • Total: 8

    Hi
    I’m just starting to use ctrlr and i have started to set up a basic editor for waldorf pulse.I have modulators working(i.e. sending midi to synth) and i’m now trying to give the controls graphics.I have loaded in to the resource page my Knob animation(made in jKnobman), but it doesn’t appear in the menu for the modulator,Is there a refresh somewhere?
    I’ve been following the step by step guide 13 and as far as I’m aware I’ve done everything.
    looking forward to an answer
    mike

    Ctrlr 5.3.198,mac osx 10.13.6,LogicX,Reaktor,E4xt,TG77,M1000,MKS70,Morpheus,Ks5000,Pulse,R8m,etc

    #69591
    PuppeteerPuppeteer
    Participant
    • Topics: 15
    • Replies: 180
    • Total: 195
    • ★★

    You need to change the uiSlider to an ImageSlider. There is a field for the graphic resource under ImageSlider, that populates from your resources.

    Also, the images only support vertical orientation not horizontal, so make sure you export as vertical out of jKnobMan.

    The Puppeteer
    http://godlike.com.au

    #69593
    mplmpl
    Participant
    • Topics: 1
    • Replies: 7
    • Total: 8

    Thanks you for prompt reply,I am using the image slider and the graphics are not appearing in the image field. I’m sure that the graphics are vertical,but I’ll check.
    I’m running the latest build on Mac OS X 10.5.

    Ctrlr 5.3.198,mac osx 10.13.6,LogicX,Reaktor,E4xt,TG77,M1000,MKS70,Morpheus,Ks5000,Pulse,R8m,etc

    #69594
    goodweathergoodweather
    Participant
    • Topics: 41
    • Replies: 443
    • Total: 484
    • ★★

    Hi, do you have the correct size for each frame in your image? What kind of image are you using (try with .png).
    Good luck!

    #69605
    mplmpl
    Participant
    • Topics: 1
    • Replies: 7
    • Total: 8

    I’ve checked the image file, it’s vertical,.png,and i’ve set the sizes.Still it doesn’t appear in the selection, just “no choices” I noticed that other panels only have the image used in the field and the selector says “no choices”.
    I tried renaming the file name in the code on the utility page, but that just reverts back when leaving the page.
    The selection menu doesn’t seam to be getting the files from “resources”.could be a mac os problem?

    Ctrlr 5.3.198,mac osx 10.13.6,LogicX,Reaktor,E4xt,TG77,M1000,MKS70,Morpheus,Ks5000,Pulse,R8m,etc

    #69607
    mplmpl
    Participant
    • Topics: 1
    • Replies: 7
    • Total: 8

    I’ve just tried an older build 5.3.122 and the graphics are available and work as expected and is still there when reloaded in the latest build,but no selection.
    this looks like a bug has got introduced in 5.3.198(Mac).

    Ctrlr 5.3.198,mac osx 10.13.6,LogicX,Reaktor,E4xt,TG77,M1000,MKS70,Morpheus,Ks5000,Pulse,R8m,etc

    #69608
    goodweathergoodweather
    Participant
    • Topics: 41
    • Replies: 443
    • Total: 484
    • ★★

    OK. I’m using a PC so can’t help you.
    Best is to register a bug (under Development menu on ctrlr.org page)…

    #69621
    mplmpl
    Participant
    • Topics: 1
    • Replies: 7
    • Total: 8

    Thank you for the help, i have reported it on the issues page
    I’ll just use the older version to edit/make panels, I’m starting with a pulse editor as it’s quite a simple one to learn with(hopefully).
    mike

    Ctrlr 5.3.198,mac osx 10.13.6,LogicX,Reaktor,E4xt,TG77,M1000,MKS70,Morpheus,Ks5000,Pulse,R8m,etc

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.
There is currently 0 users and 30 guests online
No users are currently active
Forum Statistics
Threads: 2,301, Posts: 16,149, Members: 59,523
Most users ever online was 12 on January 22, 2019 3:47 pm
Do NOT follow this link or you will be banned from the site!