Shruthi-1 Editor

Home Forums General Panels, Components, Macros Shruthi-1 Editor

Tagged: ,

Viewing 20 posts - 21 through 40 (of 40 total)
  • Author
    Posts
  • #3768
    nicore
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    thx i gona try on osx 10.7 i didn’t try this soft yet if i understand i post a comment but it look like a great job you done here <img loading=” title=”Wink” />
    nicore

    #3769
    muksys
    Participant
    • Topics: 3
    • Replies: 16
    • Total: 19

    thoroughly awesometastic! Thanks Widy for making my shruthi editor dreams come true :mrgreen:

    #3770
    snk
    Participant
    • Topics: 4
    • Replies: 19
    • Total: 23

    Thank you very much !

    #3771
    Widy75
    Participant
    • Topics: 10
    • Replies: 61
    • Total: 71

    hi no problem at all <img loading=” title=”Smile” />

    version 2.1
    smale update
    – prg change now working also with user bank
    – auto dump request if u change it on shruthi ( enable auto request + enable prg change )
    – init patch to default
    – bugfix on storage handling i sended the wt twice on recover (sry)

    lg widy

    #3772
    Anonymous
    • Topics: 0
    • Replies: 6
    • Total: 6

    I can’t get request working, any help with that?

    Both, MIDI IN & OUT are connected between soundcard and shruthi and editing patches works just fine.
    Could it be MIDI out mode setting in Shruthi-1? I couldn’t decide which mode it should be in after reading reference manual.

    I have updated firmware to v0.95.


    edit



    Argh. I got it right away after writing this post here (how else).

    I had MIDI settings configured from main window of the editor, where is that soundcard icon at the top… but i had ONLY MIDI OUT device configured in settings that could be found by clicking "panel edit mode".
    When i added MIDI IN device there, patch request worked and updated all knobs in the editor like it should.

    MIDI out mode was "Full" in Shruthi-1.
    I swithed it to "off" and it didn’t work anymore. I switched back to Full -and i was surprised it didn’t work! I tried all modes again except those that are for polychaining but could not get it working anymore.

    So, i got ONE sound requested from Shruthi-1, once.

    Could someone clarify things here.. .?


    edit



    I made some more testing.. i have used my yesterday built Shruthi-1 now one day and there is many things in its UI that bugs me. Like how in the hell i can get sequencer to stop etc.
    Refecence manual does not cover everything. I know there’s mutable-instruments forum for those questions…

    Well, i got this request working again, both ways; pushing request button and when using auto request while exploring patches.

    MIDI out mode is now Off in the Shruthi-1. Which is kinda confusing. One would think that it’s _closed_ then and same as taking cable off. I tried that too, taking MIDI out cable away from Shruthi-1 and editing sounds was working but request feature didn’t work, which was expected as MIDI traffic goes only to one direction /cable.

    I thought that i leave my experiences and thinking process here to others to see… if someone is wondering this same things someday he might get some advice out of this.

    #3773
    Anonymous
    • Topics: 0
    • Replies: 6
    • Total: 6

    Oh, and thanks for the editor. This makes editing easier and quicker for sure!

    BTW. Those store / recover buttons are [b:1qbj5yhy]excellent[/b:1qbj5yhy]!

    I am using VST version of the editor with Jeskola BUZZ, and now when i create a track i can create alternative sound choises for current track that i’m working on. Those 6 different versions come handy when trying to decide which is best sound for the song.. .

    #3774
    muksys
    Participant
    • Topics: 3
    • Replies: 16
    • Total: 19

    Hey a33e,

    Glad you are enjoying the Editor!!

    Couple of things to check. I have my Shurthi-1 (v0.95) MIDI Out set to "seq". I am able to send program changes to the Shruthi as well as request via the Editor. Also, make sure you are running the lastest ctrlr version (nightly).

    As far as switching between MIDI out modes causing the Shruthi to stop responding is odd. I am able to switch between all options without freezing the unit. Maybe post this issue on the Mutable Instruments Fourm.

    Also, getting the sequencer to stop depends what mode it is in. If it is in Sequencer Latch mode, it will stay latched until you change to a different mode. To turn the Sequencer (or arpeggiator) off, set mode to step sequencer. This is the "standard" setting for keyboard control. the UI takes a little getting used to, but once you have it figured out, it’s really quite easy to navigate. I’ve seen worse on major manufacturers. <img loading=” title=”Razz” />

    Let us know if you have any further questions and good luck!

    #3775
    Anonymous
    • Topics: 0
    • Replies: 6
    • Total: 6

    Thanks for quick answer. I think that freeze after changing MIDI out mode was not because of Shruthi, but me instead as i just got it built and it was my first day with it. I probably did too many things at the same time for troubleshooting which caused confusion about which action had which effect.
    My setup might be just too complicated, it would better to keep things direct and simple. I was trying to use VST version of this editor inside of BUZZ and at the same time direct Shruthi-1’s audio to BUZZ through ASIO input. Which caused me to use Polac’s ASIO drivers and for some reason my Laptop+Lexicon Omega combination does not like that.

    Yesterday i used M-Audio UC-16 knobs to move 8 pots of this editor. Goal was to make this all work together but i see just problems after problems. And i am systems administrator in IT industry so i know more than basics about devices, drivers, computer hardware, OS’es etc.
    That ASIO input combined with this CTRLR editor would just be killer combination -using all those BUZZ effects with Shruthi-1!

    BTW. One reason why i got too much spam out of sequencer / arp perhaps was that i had MIDI out mode set to "full". Manual says: "In this mode, every incoming message is forwarded to the Midi output."
    And i had both, MIDI IN and OUT cables connected..

    I’ll keep practicing!

    #3776
    Anonymous
    • Topics: 0
    • Replies: 6
    • Total: 6

    Now everything works again. :shock: & :roll:

    So i have CTRLR editing Shruthi-1’s sound which goes through Lexicon and Polac’s ASIO drivers and ASIO input machines to BUZZ. I added some effects like flanger and reverb to beefy acid sound.. sounds goooood!

    But this system is [b:1ymaveif]a bit[/b:1ymaveif] too unstable. <img loading=” title=”Razz” />

    #3777
    Widy75
    Participant
    • Topics: 10
    • Replies: 61
    • Total: 71

    hi
    version 2.5 (2.3 and 2.4 never released just internal releases <img loading=” title=”Smile” />
    -changes for latest 0.96 Firmware (19April) ( the prev 0.96 did not handle operators in the right way )
    — operator handling
    — osc1 = osc2 and correct some namings
    — OSX Mix all from DUO to SEQMIX
    — MOD Matrix Source Destination adaptation
    -fix fpr automation in daw ( e.g repaer did not update the env in track on changes of values directly on shruthi, forgot the update to the daw on parameter changes ..wuahh)
    -dynamic osc mix naming on osc op settings e.g FUZZ now called AMOUNT on OSC MIXer
    -patch name correct for names < 8 chars <img loading=” title=”Smile” />

    have fun blues widy

    #3778
    Widy75
    Participant
    • Topics: 10
    • Replies: 61
    • Total: 71

    just let u to know that im working for an new version ( just fixes ) to run it on the lates ctrlr

    #3779
    Filch
    Participant
    • Topics: 22
    • Replies: 173
    • Total: 195
    • ★★

    Glad to hear it!

    #8195
    muksys
    Participant
    • Topics: 3
    • Replies: 16
    • Total: 19

    I’ve had a couple people request v2.5.  I don’t have this version.  The latest I have is V2.2 which is attached.  Does anyone have 2.5 they could share?

    Attachments:
    You must be logged in to view attached files.
    #8286
    muksys
    Participant
    • Topics: 3
    • Replies: 16
    • Total: 19

    Ok, attached is V2.5.  According to Widy75, it works best with ctrlr v925.   Newer versions generates errors.  He said there was a change in how the scripting works (that stuff is waaay over my head).  From what I gather, it’s more an issue when used as a VST.  Dunno.  At any rate, enjoy!

    Attachments:
    You must be logged in to view attached files.
    #8513
    topaz
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    thanks for the editor, i am seeing lots of  errors on start

    also the mouse cursor vanishes when hovering over controls.

    Attachments:
    You must be logged in to view attached files.
    #9582
    SEED78
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    I’ve got a Shruthi Polivoks – can I use this editor with it?

    #11430
    rhashime
    Participant
    • Topics: 0
    • Replies: 1
    • Total: 1

    Just a heads up, I’ve started working on cleaning up this editor to work with the latest version of CTRLR. I’ve got it loading cleanly, but I am having to gut some of the features for the time being. I had to kill the ui midi keyboard beacuse notes get stuck even on a new panel (major bug). The WAV transfer bits are causing some issues too (I’ll probably remove them). Everything else seems to be working. CTRLR is a neat application, I just wish it wasn’t so wonky (it is off topic for this post, but I will detail my frustrations in another one). I’m going to go through and try to clean up the code as well. It’s been a pain because the LUA editor’s “find” doesn’t work and the original authors grouped multiple functions under many of the LUA methods, making difficult to find who’s calling who. Anyhow I still am very grateful Widy75 and Muksys put this together. I’ll see if I can get a daft copy with my changes out by the end of the week.

    #11434
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I can only imagine what Wonky means 🙂

    I hope it gets better, anyway i fixed the FIND in code feature, i didn’t know it was broken. my bad sorry for that.

    #19300
    Dr3Tri
    Participant
    • Topics: 2
    • Replies: 9
    • Total: 11

    Any progress? Will it have 4PM filter mode options?

    #117064
    AndyHornBlower
    Participant
    • Topics: 1
    • Replies: 6
    • Total: 7

    Ok, attached is V2.5. According to Widy75, it works best with ctrlr v925. Newer versions generates errors. He said there was a change in how the scripting works (that stuff is waaay over my head). From what I gather, it’s more an issue when used as a VST. Dunno. At any rate, enjoy!

    Thanks. I probably ought to just try try the recommended version of Ctrlr, but I may try to get it working in the one I’ve been using, with Version = 5.4.52.

    So far, I’ve only fixed the problem of the disappearing mouse pointer, but I’m attaching that before I mess anything else up.

    It seems the meaning of the value for componentMouseCursor must have changed, so this probably doesn’t work in the older version of Ctrlr…

    Trying to attach the .panel gives me an error:

    413 Request Entity Too Large

    – so I’m (hopefully) adding it in a zip, instead.

    Attachments:
    You must be logged in to view attached files.
Viewing 20 posts - 21 through 40 (of 40 total)
  • The forum ‘Panels, Components, Macros’ is closed to new topics and replies.
There is currently 0 users and 62 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr