sweep modwheel – every combo box flips

Home Forums General Using Ctrlr sweep modwheel – every combo box flips

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #754
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    I have a user of my microwave panel who is using a microwave XTk (keyboard version) of the synth with my panel. I have not noticed this issue or had anybody report it at all until a few weeks ago. He was telling me that when he would sweep the modwheel on the synth (which sends the typical modwheel cc01) a program change would occur from the ctrlr panel. I double checked that nothing involved with program select on my panel was set to send/receive CC01. I just have the XT rackmount version which has no modwheel so i’ve set my emu xboard as the MIDI input to my panel, do a modwheel sweep and sure enough after about a 5 second lag every/most every combobox on my panel flipped values. NONE of these modulators are set to send/receive MIDI CC01. Nothing on the panel through Lua or otherwise touches or deals with CC01.

    What could be causing this? I’ve been seeing it since ctrlr 1102 and now that I actually see what he’s seeing I’m a bit mystified.

    I just created a new blank panel from scratch and added a few comboboxes, even copied over some comboboxes from the monstrumWave panel in question and I can replicate the issue on the pasted comboboxes in the new test panel.

    Then 5 minutes later after restarting ctrlr and clearing the cache I’m no longer able to reproduce the issue on a blank panel. very bizarre, would love to hear some input from other users. Atom I’m PM’ing you the panel in question.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4930
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    I’ve had similar issues with the modwheel. In my case, moving the modwheel changed the value of modulator with vst index = 0. Assigning another vst index solved the problem.

    #4931
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Hey thanks for the reply das. Good to know at least somebody has seen this or something similar.. unfortunately it doesn’t look like this has to do with the vst index as every modulator in question is set to something other than vst index 0… hmm.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4932
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I’ll try to reproduce this, place some combos on the panel and transmit CC01 to the panel and some bad stuff happens is that it ?

    #4933
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    Yeah, check your PM atom, I sent you the actual panel in question. I’m really curious why those combo boxes flip out when the panel receives a CC01.
    I had various levels of "success" reproducing this with a blank panel, so to see it actually happen look at the panel I sent you in a PM.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4934
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    i didn’t get any PMs…

    #4935
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Well new combos do that cause i had set it to CC 1, but once i set the MIDI type to None it stopped reacting to MIDI. By default it’s CC#1

    #4936
    msepsis
    Participant
    • Topics: 219
    • Replies: 732
    • Total: 951
    • ★★★

    like i said.. none of the modulators in question are set to CC01. Did you get my resend? I just pm’d you again..twice.

    Some of the modulators that are reacting to a modwheel sweep are set to none, some are set to sysex, with the CC number set to 0.

    Monstrum Media | Music, Sound & Software Design, Chicago / San Francisco listen

    #4937
    Synthetech
    Participant
    • Topics: 13
    • Replies: 70
    • Total: 83

    This happens to my panel too..

    while the panel is up, I have a Program CHange combobox.

    When I move the modwheel on my KB, the numbers change in the combobox.

    The problem occurs when Ctrlr receives a modwheel midi message.

    #4938
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    I’m working on it.

Viewing 10 posts - 1 through 10 (of 10 total)
  • The forum ‘Using Ctrlr’ is closed to new topics and replies.
There is currently 0 users and 74 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr