Virus TI Snow Panel

Home Forums General Panels, Components, Macros Virus TI Snow Panel

Viewing 20 posts - 21 through 40 (of 45 total)
  • Author
    Posts
  • #3237
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    I have uploaded a new update of the panel.

    · Now you can open one panel to control each of the four parts of the Snow, and make dump requests on each part.

    · There are a few improvements in the LCD. It shows on the upper line the name of the patch loaded from a bank of the Snow to the left; icons for note in, for cc in with number of incoming cc and sysex in to the right; and all modulators displays the internal value on the left and the midi value on the rigth of the second line.

    · Added some config parameters (led intensity, tuning, enable/disable all delays, reverbs, arps and eqs)

    · Added inputs parameters (Boost, Thru, Sensitivity, Characteristic)

    · Added the name of the presets in the Rom Banks.

    I have not tested the panel in a sequencer yet, all has been done in standalone mode, this will be the next thing to do.

    The panel uses some fonts that are not included. They come from a Yamaha Motif Xs Editor I have installed and it’s free to download. I don’t know if I can upload here a file with the fonts, as I don’t know if they are free. (Atom??? :roll: )

    #3238
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    well i have no problem with that, but if the cops come knocking, i aint tellin them anything.

    actualy the whole "copyright issue" is what’s stopping me from embedding fonts in panels, and it can be done.

    #3239
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    It could be fantastic if fonts were embedded, but I understand the problems it could generate.

    Here are the fonts.

    #14891
    essay
    Participant
    • Topics: 1
    • Replies: 3
    • Total: 4

    Dasfaker, you job is smth outstanding.

    But for me
    MIDI plays out of time, can you please advise?
    What should I adjust generally and exactly in logic pro 9?

    #14893
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    Hi essay, thx for your kind words.

    I’m on pc, so I can’t help you with Logic. This latency seems related to Logic or Ctrlr, not the panel itself.

    On Ableton Live you can adjust track delay to compensate this latency, there should be a similar option in Logic.

    Hope that helps.

    #28528
    dest4b
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    hi,

    i found this .. and i am happy as hell 🙂
    to get rid of Virus control 😀

    but .. if i want to read the RAM / ROM patch banks. i get
    “communication error”

    i tried that in ableton and in standalone CTRL in both cases i am able to remote the virus from ctrl and i am also able to move the Knobs on the screen by turning the virus encoders .. so it is working in both ways ..

    what is my error ? IS it only working with the midi in/out . I tried it with USB connection. Because my Virus is in a rack and connected with midi to a hardware sequencer.

    VIRUS Ti 1
    Win8 64
    16Gb
    Ableton 9.1.4 32bit ( i dont get ctrl in 64bit version running )
    latest CTRL

    CTRL configured:
    IN: Virus Ti Synth (USB)
    Out: Virus Ti Synth (USB)
    Device: Virus Ti Synth (USB)

    thank you ! 🙂

    • This reply was modified 7 years, 9 months ago by dest4b.
    #28533
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    Hi dest4b

    but .. if i want to read the RAM / ROM patch banks. i get
    “communication error”

    Make sure the Virus accepts incoming midi dumps (Config -> Receive MIDI Dump -> Receive Dump: Enabled)

    what is my error ? IS it only working with the midi in/out . I tried it with USB connection. Because my Virus is in a rack and connected with midi to a hardware sequencer.

    It’s strange, I can use both MIDI and USB ports. It could be that, as you are using the MIDI ports with the hardware sequencer, the USB port is not enabled at the same time. Did you try using only the USB port with Ctrlr and remove the MIDI port connection?

    CTRL configured:
    IN: Virus Ti Synth (USB)
    Out: Virus Ti Synth (USB)
    Device: Virus Ti Synth (USB)

    It’s not necessary the Device port, as this is used to control the panel with an external controller.

    #28534
    NoNameNeeded
    Participant
    • Topics: 2
    • Replies: 11
    • Total: 13

    Where can I find this panel?

    #28535
    dest4b
    Participant
    • Topics: 0
    • Replies: 2
    • Total: 2

    Access Virus TI

    here….

    It is set to receive midi dump .

    The hardware sequencer is powered off.
    unplugging it would be a bigger action it is with the ti in a rack

    just plugged it in with midi.. it is working.
    But i cant disconnect my midi setup 😉

    So is it working with USB normally ?

    • This reply was modified 7 years, 9 months ago by dest4b.
    #28536
    NoNameNeeded
    Participant
    • Topics: 2
    • Replies: 11
    • Total: 13

    Is something like this also available for the Virus B?

    #28538
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    It is set to receive midi dump .

    The hardware sequencer is powered off.
    unplugging it would be a bigger action it is with the ti in a rack

    just plugged it in with midi.. it is working.
    But i cant disconnect my midi setup 😉

    So is it working with USB normally ?

    Yes, it works with USB and MIDI ports. I just checked it, also the browser is working fine. If message “No communication with Virus TI” appears is because there is no reply from the Virus after a dump request.

    About using both MIDI and USB ports at the same time, when you plugin the USB, the virus physical midi ports change operation, they turn the virus into a midi hub, so you can direct midi to other devices through it.
    You cannot use them to communicate to synth engine, this has to be done via USB.

    #33754
    spinacem
    Participant
    • Topics: 8
    • Replies: 38
    • Total: 46

    Hello!

    I was trying the virus panel but i have some problems with most of the parameters not showing in reaper (for example cutoff filter or resonance). It seems i can’t automate those parameters on reaper. The strange thing is that this is possible in ableton. I’ve also tried to export instance-vst to see if that helps but no changes. Any ideas?

    #33831
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    I’ve installed Reaper and everything seems ok.

    Remember to place the file Ctrlr.overrides in the same folder where is installed the plugin Ctrlr.dll, rename it to the same name of the plugin and extension override (in my case is “Ctrlr-VST-x64.overrides”), and set the changes listed below, otherwise you could only see 64 parameters (and none of them are related to the synth engine).

    <?xml version="1.0" encoding="UTF-8"?>
    
    <ctrlrOverrides 	ctrlrMaxExportedVstParameters="5000" 
    			ctrlrShutdownDelay="256" 
    			ctrlrUseEditorWrapper="1" 
    			ctrlrLuaDisabled="0"
    			ctrlrLogToFile="0"
    			/>
    #33848
    Julofoideveau
    Participant
    • Topics: 0
    • Replies: 5
    • Total: 5

    Hi !
    This panel looks amazing, congratulations, and I cannot wait to try it. Unfortunately I am having some issues making it work ..
    I am currently running live 9 with the TI Snow, and it seems like I cannot have any kind of communication between Ctrlr and my Snow.
    I have set it up so it can receive MIDI Dump, and I also have set Global Channel and Midi Device to 1.
    Inside Ctrlr I have set MIDI Input and Output to Virus TI Snow Synth. (Ctrlr tells me Open : OK for both)
    But when I try to get the current patch for instance, nothing happens. Same if I go within the patch browser, and I get “No communication with Virus TI”. No sounds if I play a midi clip within live either.
    I have this problem on both AU and Standalone version of Ctrlr, which is why any kind of help would be greatly appreciated at this stage 😉
    Thanks !

    #33854
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    Maybe you have the Virus midi port opened by other application?. Try running Ctrlr standalone and be sure the port is only used by Ctrlr. To me this is a communication problem, for some reason Ctrlr is not sending or receiving midi data.

    If message “No communication with Virus TI” appears is because the panel has sent to the Virus a program request and it hasn’t received any incoming midi message.

    #33883
    Anonymous
    • Topics: 0
    • Replies: 1
    • Total: 1

    Hey there!
    first of, AMAZING work!
    Exactly what i was looking for!
    I could need some help though, since i could not find anything about it in the documentation, forum or web.
    I would like to use ctrlr and your panel for my Virus TI Snow within Maschine Studio.
    Reason is, that i wish to record automation’s but the TI plugin does only allow to midi learn the very basic controls and none of the fun stuff…
    This is where i stumbled over ctrlr and your panel.
    The vst is loaded as plugin in a sound slot within Maschine Studio 2.2 and the accept midi dump on the virus is enabled. Device ID is 01 and the midi channel is 01 as well.
    I selected for Input, Controller and Output the Virus TI Synth. Green bar/message on the bottom and the 🙂 smiley face confirmed the successful connection.
    I was able to control and tweak as the virus was plugged in through USB. the “Get” button and all knobs and sliders work and so does the midi learn within Maschine! Yay so far!
    Where i ran into an issue was the browser. If i try to select a bank i get the attached error message “callback error.PNG”
    I then searched around and i thought i give it a shot disconnecting USB and running it straight through midi, but i miserably failed.
    Do you have eventually some suggestions for me?
    I also want to say that i am not quite sure if i select the correct midi channels or have it wired correctly. I would really appreciate if you could help me getting it set up.
    Thanks so much in advance!

    #33890
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    This seems an issue with an old Ctrlr version. Can you tell me which one are you using?

    Also, I see from the image attached that you didn’t installed the fonts included in the download link, that’s why the fonts are so small in the image.

    #33958
    Julofoideveau
    Participant
    • Topics: 0
    • Replies: 5
    • Total: 5

    Thank you for the reply !
    It now seems to work pretty well 🙂

    Now, any Live user here who could help me understand how to send midi notes to the virus via Ctrlr ?

    #33960
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    The panel select at startup the correct values for midi thru options, so you should hear the virus as you play (if the track is armed) or play some clip.

    Ctrlr thu settings

    #36776
    Julofoideveau
    Participant
    • Topics: 0
    • Replies: 5
    • Total: 5

    Hello again, and thank you for the reply, did not have the time to try your solution until now. I am glad to see that almost everything seems to be functional now. Having zero latency is such a great improvement 🙂

    Only issue left for me is the bi-directional communication .. If I move the filter inside ctrlr for instance, the virus does not receive the changed value unless I press the “send” button. Which is unfortunate because it does not allow me to use automation, and for every parameter changed, I need to send the patch in order to hear the changes.
    I tried using my komplete 6 midi in and out inside ctrlr instead but the problem remains the same. Tried both on AU and VST also.

    Any idea where the problem might come from ?

Viewing 20 posts - 21 through 40 (of 45 total)
  • The forum ‘Panels, Components, Macros’ is closed to new topics and replies.
There is currently 0 users and 54 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr