Visual Studio 2010 and 2013 builds are broken

Home Forums General Programming Visual Studio 2010 and 2013 builds are broken

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30697
    synth
    Participant
    • Topics: 13
    • Replies: 35
    • Total: 48

    It says :

    Add directive to ‘stdafx.h’ or rebuild precompiled header
    1>..\..\..\..\Juce\modules\juce_opengl\juce_opengl.cpp(201): warning C4627: ‘#include “native/juce_OpenGL_linux.h”‘: skipped when looking for precompiled header use
    1> Add directive to ‘stdafx.h’ or rebuild precompiled header
    1>..\..\..\..\Juce\modules\juce_opengl\juce_opengl.cpp(204): warning C4627: ‘#include “../juce_core/native/juce_android_JNIHelpers.h”‘: skipped when looking for precompiled header use
    1> Add directive to ‘stdafx.h’ or rebuild precompiled header
    1>..\..\..\..\Juce\modules\juce_opengl\juce_opengl.cpp(205): warning C4627: ‘#include “native/juce_OpenGL_android.h”‘: skipped when looking for precompiled header use
    1> Add directive to ‘stdafx.h’ or rebuild precompiled header
    1>..\..\..\..\Juce\modules\juce_opengl\juce_opengl.cpp(209): warning C4627: ‘#include “opengl/juce_OpenGLContext.cpp”‘: skipped when looking for precompiled header use
    1> Add directive to ‘stdafx.h’ or rebuild precompiled header
    1>..\..\..\..\Juce\modules\juce_opengl\juce_opengl.cpp(212): fatal error C1010: unexpected end of file while looking for precompiled header. Did you forget to add ‘#include “stdafx.h”‘ to your source?

    This seems to be happening for the Visual Studio 2013 project too.

    #30698
    atomatom
    Participant
    • Topics: 157
    • Replies: 2943
    • Total: 3100
    • ★★★★★

    They are not broken, this is a feature not a bug 🙂

    When you save a project with Introjucer, there is not option to exclude source files from using precompiled headers (stdafx.cpp/h) so you need to do that manually everytime you re-save the Introjucer project.

    Also you may notice the x64 is not an architecture in the project, you need to add it first.

    So add the x64 arch.

    Then exclude all juce_*.cpp files, all LuaSocket files (i’ll remove those soon since we don’t need them i think), the lua.c file, and all the .c files in the Native/Linux folder.

    Then it will build.

    It’s tricky you need to select those files, right click, select C/C++ options, select “Not using precompiled headers” and then select Advanced or Command line and uncheck a small checkbox on the bottom right corner that tells something about inheriting options from parent solutions.

    THEN you need to click on stdafx.cpp and select “Create precompiled headers” in the same option.

    And yes everytime i change something in Introjucer i have to do that again (i wanted too do some kind of macro for that but never managed to get it working)

    #30704
    synth
    Participant
    • Topics: 13
    • Replies: 35
    • Total: 48

    Ah cool 🙂 I ll try it.

    Thanks that worked !

    • This reply was modified 6 years ago by synth.
Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.
There is currently 1 user and 31 guests online
drno
Forum Statistics
Threads: 2,439, Posts: 17,199, Members: 53,083
Most users ever online was 12 on January 22, 2019 3:47 pm
Do NOT follow this link or you will be banned from the site!