Home Forums General Using Ctrlr Mapping controllers to Ableton parameters (Also labels)

This topic contains 8 replies, has 5 voices, and was last updated by  niels@dettenbach.de 10 months, 4 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #16640

    JoeMatt
    Participant

    2 part question.

    1) I have a panel I’m using (the new Bass Station 2 panel posted to Novation’s forum) When I’m in Ableton Live and set the plugin to configure mode so I can automate values in the panel, Live doesn’t notice when I click or move a knob for this panel. It works in the other panel I tried though (juno 106). Is there something that needs to be added to a control to get it to be recognized in Live?

    2) As mentioned above, the 106 panel works with automation, but when click a control it shows a generic title like “automater_4”. Is there a way to configure the panel to have a custom name so I can actually figure out what parameter I’m automating? If not, feature request!.

    edit: Nevermind, I figured out how to change the values for question #2. There’s a property called Name (duh). They just weren’t set in this panel. Still learning…

    • This topic was modified 3 years, 4 months ago by  JoeMatt.
    #17081

    Onedayhero
    Participant

    Hey, I have the same issue. When I want to learn some controls from my DAW, it doesn’t pick up if I change the value of a knob so it can’t learn the parameter I want to use for automation. Have you figured out what you need to change in Panel mode (besides name) to get the parameter to be learned from the DAW?

    #17082

    Onedayhero
    Participant

    (also using the BS2 panel from the novation forums)

    #17431

    JoeMatt
    Participant

    I figured it out. If you click a control in edit mode it has a VST Index value. I’m assuming there’s a valid range that will be accepted here as setting to lower values. The maximum value seems to be 64. I tried the VST and AU wrappers and this applies to both.

    I’m not sure if this is a Live limitation, VST limitation or ctrlr bug. 64 seems like a low number so I’m suspicious it’s ctrlr in this case.

    • This reply was modified 3 years, 3 months ago by  JoeMatt.
    #17436
    opuswerk
    opuswerk
    Participant

    You can change the maximum amount of VST index exports in ctrlr preferences. I’ve set mine to 512 in case 256 is not enough.

    http://opuswerk.tumblr.com
    www.soundcloud.com/opuswerk
    www.facebook.com/opuswerk

    #17576
    atom
    atom
    Moderator

    The 64 is a default for a Ctrlr started in normal mode, it needs a value. The problem with that number is that the host asks for that number on load and never asks for it again, so you can’t change the number during the panel lifetime AND the question about the number is sent before the plugins state is loaded by the host so you can’t really respond with the correct value.

    Anyway you can set the number to something very high (and i can do that in the source code) BUT that makes the load time of an empty Ctrlr significantly longer (enough to be noticed by a normal user).

    This limit is not present when exporting an instance, because in an instance Ctrlr knows how many parameters it should report to the host on start (that’s why the instance is embedded inside).

    #17627
    opuswerk
    opuswerk
    Participant

    oh, that’s very good to know.
    Do the number of parameters have anything to do with the VST Index number? or is it independent?

    http://opuswerk.tumblr.com
    www.soundcloud.com/opuswerk
    www.facebook.com/opuswerk

    #17628
    atom
    atom
    Moderator

    The index must be below the max number of reported parameters.

    If you report 100 parameters you can’t have index 100 or higher only 0-99 (that’s a hundred parameters starting with index 0)

    #69376

    niels@dettenbach.de
    Participant

    Ok, so could someone explain how to solve that in steps?

    Ive seen that vstIndex is going up to 650 – so i’ve set in “edit” – “preferences” – “max exported VST params” up to 800 (from 64 what seems default), saved ctrlr state and generated new VST exports, but without any luck in getting live mapping to work.

    Or should i rewrite an vstIndex numbers to lower ones (seems “randomly” distributed between 100 and 650)?

    Or did i miss something?

    Have the same effect in an older SHRUTI ctrlr panel which works otherwise as expected for me. I’m open to contribute my working changes as updates in case i find to there…ß)

    many, many thanks for any hint,

    Niels.

    • This reply was modified 10 months, 4 weeks ago by  niels@dettenbach.de. Reason: just to get notifications

    ((d^b))
    dettenbach
    music fab

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Comments are closed.