ALSA Midi Devices / How to build from source

Home Forums Platform Specific Linux ALSA Midi Devices / How to build from source

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #616
    romsom
    Participant
    • Topics: 3
    • Replies: 27
    • Total: 30

    I’ve been trying to use ctrlr on Linux for the last days.

    First I tried the binary. (BTW I’m an archlinux user, so I built a package via AUR)
    This seemed to work fine, with the only problem being that no MIDI devices are recognised. <img loading=” title=”Wink” />
    As a few other linux users also had this problem: Did you find a solution?

    Noticing that the linux builds are rather old, I tried to compile ctrlr from source.
    I got the code from SVN as described in this thread[/url:14ram9ep] posted a year ago.
    I found the "Build_linux.sh" script but don’t quite get how to use it.
    Could you describe the "official" procedure the get the source compiled on/for linux?

    I consider myself an experienced linux user with (slightly above) scriptkiddie-like coding skills. <img loading=” title=”Wink” />
    Greets, Roman

    #4386
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Well that old thread is still valid. Try to get the Introjucer binary running and do as the thread says, adjust your paths inside Introjucer, and it should generate a valid Makefile for Ctrlr.

    #4387
    romsom
    Participant
    • Topics: 3
    • Replies: 27
    • Total: 30

    I’ll try that, thanks!

    #4388
    romsom
    Participant
    • Topics: 3
    • Replies: 27
    • Total: 30

    Well, compiling worked at last (minor adjustments necessary).

    Still with rev1039 the MIDI Device Problem stays the same; no devices are recognised. Do you have any hints for that?

    #4389
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Well i can’t really say anything cause i have no test platform for linux devices, there is some discussion on the JUCE forums http://www.rawmaterialsoftware.com/view … f=5&t=8143 about alsa, maybe we need to wait for a fix from JJUCE. I’m also considering using RtMIDI library for MIDI device handling but i need to think about that (if it’s a good idea) it supports linux too.

    #4390
    romsom
    Participant
    • Topics: 3
    • Replies: 27
    • Total: 30

    Sorry for my late reply!

    I had a brief look on RtMidi and it seems quite superior to the "standard solution", so if it’s feasible, it has my vote! <img loading=” title=”Wink” />

    Also let me know if I can help you by testing or anything else. I quite a few Linux machines lying around anyway, on which a plan to use ctrlr.

    EDIT: BTW: have you considered using jack for midi on linux?

    #4391
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    RTMIDI has JACK support for MIDI so that would work, i use linux everyday at work and at home but i never used it for audio stuff, i never used JACK only ALSA. Does JACK use it’s own hardware interface for MIDI or is it just a layer that uses ALSA ?

    #4392
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Also i wasn’t able to get any of my MIDI devices to work on linux, i haven’t tried the ESI m8u XL that might work.

    #4393
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Quick update I tried linux yesterday with my esi m8u xl connected to the vm I’m running linux mint. I noticed that the project setting for alsa was disabled in introjucer and that’s the reason for not seeing any devices. There is also an option for jack support in introjucer but I haven’t tried that. Try to update the sources from the svn and rebuilf. Ctrlr should see alsa devices, that worked for me.

    #4394
    romsom
    Participant
    • Topics: 3
    • Replies: 27
    • Total: 30

    Strangely it still doesn’t work for me. With the new version (thx anyway <img loading=” title=”Wink” /> ) there is no more "MIDI Device Settings" button and Ctrlr still does not show up in qjackctl (neither as jack-, nor as alsa-midi device).
    I won’t give up yet, though. <img loading=” title=”Wink” />

    #4395
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    The new ctrlr builds don’t have the MIDI Device settings icon, you select the device in the panel properties (Right click on panel or lick a red-eye icon on the panel toolbar)

    #4396
    romsom
    Participant
    • Topics: 3
    • Replies: 27
    • Total: 30

    Damn, that was fast!
    I does seem to work now.
    Thx for your time!

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘Linux’ is closed to new topics and replies.
There is currently 0 users and 57 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr