Lua functions not being saved – build 5.3.122

Home Forums Platform Specific Windows Lua functions not being saved – build 5.3.122

Tagged: , ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #59019
    Hecticcc
    Participant
    • Topics: 25
    • Replies: 160
    • Total: 185
    • ★★

    Hi all!

    After a looong break i finally have time and space again to get building and started a fresh panel to get back into it, but after re-opening the panel today all my Lua functions were gone…

    I am trying older builds now to see if it may be my setup, but it looks like the problem is @ Ctrlr because the other elements of the panel (mods, colours, panel size, name etc) are saved correctly.

    Made a ticket @ http://ctrlr.org/issue-tracker/lua-scripts-not-being-saved-with-panel–windo/

    • This topic was modified 6 years, 7 months ago by Hecticcc.
    #59065
    zeoka
    Participant
    • Topics: 73
    • Replies: 466
    • Total: 539
    • ★★★

    i had the issue two times some time ago , i lost all LUA code
    now i verify when i save if all is there and i do a backup time from time

    #59071
    Hecticcc
    Participant
    • Topics: 25
    • Replies: 160
    • Total: 185
    • ★★

    Hi Zeoka, good to see you’re still around 😉
    Thanks for confirming it is not my setup.
    What version works for you? I cannot have Lua being gutted because the panel i work on heavily relies on it.

    Fwiw I switched to using git on a headless machine to store all my work, and i spotted that the panels i opened were also modified. Looking into them revealed the same bug – all Lua gone.

    But thanks to git i can restore easily -phew 🙂
    Btw i strongly recommend all here to use git, besides being a headache most of the time it actually is a lifesaver.

    #69199
    dasfaker
    Keymaster
    • Topics: 80
    • Replies: 793
    • Total: 873
    • ★★★

    There is a bug here. Opening a panel with LUA disabled and saving the panel will delete all LUA methods, be careful.

    #69221
    atom
    Keymaster
    • Topics: 159
    • Replies: 2945
    • Total: 3104
    • ★★★★★

    Please report this and any other bug on github i’m getting back slowly into coding and i should be able to fix those big ones soon.

    #69227
    m.tarenskeen
    Participant
    • Topics: 30
    • Replies: 113
    • Total: 143
    • ★★

    There is a bug here. Opening a panel with LUA disabled and saving the panel will delete all LUA methods, be careful.

    I found your warning about this bug a few days *after* I had bumped into it myself. Ouch. This is a really ugly one.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Windows’ is closed to new topics and replies.
There is currently 0 users and 30 guests online
No users are currently active
Forum Statistics
Threads: 2,495, Posts: 17,374, Members: 77,605
Most users ever online was 12 on January 22, 2019 3:47 pm
Ctrlr